Mac系统下Cocoapods安装使用方法



环境

Mac系统版本:Mac OS X EI Capitan 10.11.5
Xcode版本:7.3.1
Rvm版本:1.27.0
Ruby版本:2.3.0


(1)升级Ruby环境

$ sudo gem update --system

(2)安装CocoaPods时我们要访问cocoapods.org,用淘宝的RubyGems镜像来代替官方版本,执行以下命令:
$ gem sources --remove https://rubygems.org/
//等有反应之后再敲入以下命令
$ gem sources -a https://ruby.taobao.org/
(3)为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:
$ gem sources -l
(4)只有在终端中出现下面文字才表明你上面的命令是成功的:
*** CURRENT SOURCES ***

http://ruby.taobao.org/
(5)安装Cocoapods,在终端输入命令:
$ sudo gem install -n /usr/local/bin cocoapods
//再加一句,完美解决(根据实际情况,有时不需要Xcode.app是应用程序里面Xcode的名称一定要写正确)
$ sudo xcode-select --switch /Applications/Xcode.app
(6)完成安装(需要等些时间,加载列表出现gems installed表示安装完成)命令:
$ pod setup
(7)安装失败的话重新安装命令:
$ pod repo remove master  
$ pod setup
(8)搜索第三方库

$ pod  search  AFNetworking

(9)Xcode新建工程cocoapodsSample

(10)终端使用命令cd,cd后面跟的是工程目录名,可以直接拉进来,回车后,输入命令创建Podfile文件:
$ touch Podfile
(11)使用vim编辑podfile文件,使用命令:
$ vim Podfile
(12)在Podfile文件中输入以下文字:
platform :ios, '7.0'
target 'cocoapodsSample'do
  pod 'AFNetworking', '~> 2.6'
  pod 'ORStackView', '~> 3.0'
  pod 'SwiftyJSON', '~> 2.3'
end
另外一种写法
def pods
  pod 'AFNetworking', '~> 2.6'
  pod 'ORStackView', '~> 3.0'
  pod 'SwiftyJSON', '~> 2.3'
end
target 'cocoapodsSample'do
  pods
end
(13)在编辑完后按 esc,然后按":",这个时候输入wq保存退出。
(14)这时候,你就可以利用CocoPods下载AFNetworking类库了。还是在终端中的当前项目目录下,运行以下命令:
$ pod install 
(15)等待安装成功提示

(16)这个时候,会看到多了一个.xcworkspace工程,以后打开项目就用 cocoapodsSample.xcworkspace 打开,而不是之前的.xcodeproj文件。
(17)如果有一些包已经存在了,或者我们更改了Podfile里面的版本,可以使用以下命令更新:
$ pod update


备注:

(一)关于Podfile文件编辑时,第三方库版本号的各种写法:
pod ‘AFNetworking’      //不显式指定依赖库版本,表示每次都获取最新版本
pod ‘AFNetworking’,  ‘2.0//只使用2.0版本
pod ‘AFNetworking’, ‘>2.0//使用高于2.0的版本
pod ‘AFNetworking’, ‘>=2.0//使用大于或等于2.0的版本
pod ‘AFNetworking’, ‘<2.0//使用小于2.0的版本
pod ‘AFNetworking’, ‘<=2.0//使用小于或等于2.0的版本
pod ‘AFNetworking’, ‘~>0.1.2//使用大于等于0.1.2但小于0.2的版本,相当于>=0.1.2并且<0.2.0
pod ‘AFNetworking’, ‘~>0.1//使用大于等于0.1但小于1.0的版本
pod ‘AFNetworking’, ‘~>0//高于0的版本,写这个限制和什么都不写是一个效果,都表示使用最新版本
(二)Ruby的安装版本和默认设置的版本一定要对应

(三)使用CocoaPods来添加第三方类库,无论是执行pod install还是pod update都卡在了Analyzing dependencies不动

原因在于当执行以上两个命令的时候会升级CocoaPods的spec仓库,加一个参数可以省略这一步,然后速度就会提升不少。加参数的命令如下:


$ pod install --verbose --no-repo-update

$ pod update --verbose --no-repo-update


(四)往Xcode上安装插件管理器的方法     


(1)登录下面的网站


(2)安装插件管理器:终端执行如下命令


//删除插件管理器:终端执行如下命令

$ rm -rf ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/Alcatraz.xcplugin
环境

Mac系统版本:Mac OS X EI Capitan 10.11.5
Xcode版本:7.3.1
Rvm版本:1.27.0
Ruby版本:2.3.0


(1)升级Ruby环境

$ sudo gem update --system

(2)安装CocoaPods时我们要访问cocoapods.org,用淘宝的RubyGems镜像来代替官方版本,执行以下命令:
$ gem sources --remove https://rubygems.org/
//等有反应之后再敲入以下命令
$ gem sources -a https://ruby.taobao.org/
(3)为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:
$ gem sources -l
(4)只有在终端中出现下面文字才表明你上面的命令是成功的:
*** CURRENT SOURCES ***

http://ruby.taobao.org/
(5)安装Cocoapods,在终端输入命令:
$ sudo gem install -n /usr/local/bin cocoapods
//再加一句,完美解决(根据实际情况,有时不需要Xcode.app是应用程序里面Xcode的名称一定要写正确)
$ sudo xcode-select --switch /Applications/Xcode.app
(6)完成安装(需要等些时间,加载列表出现gems installed表示安装完成)命令:
$ pod setup
(7)安装失败的话重新安装命令:
$ pod repo remove master  
$ pod setup
(8)搜索第三方库

$ pod  search  AFNetworking

(9)Xcode新建工程cocoapodsSample

(10)终端使用命令cd,cd后面跟的是工程目录名,可以直接拉进来,回车后,输入命令创建Podfile文件:
$ touch Podfile
(11)使用vim编辑podfile文件,使用命令:
$ vim Podfile
(12)在Podfile文件中输入以下文字:
platform :ios, '7.0'
target 'cocoapodsSample'do
  pod 'AFNetworking', '~> 2.6'
  pod 'ORStackView', '~> 3.0'
  pod 'SwiftyJSON', '~> 2.3'
end
另外一种写法
def pods
  pod 'AFNetworking', '~> 2.6'
  pod 'ORStackView', '~> 3.0'
  pod 'SwiftyJSON', '~> 2.3'
end
target 'cocoapodsSample'do
  pods
end
(13)在编辑完后按 esc,然后按":",这个时候输入wq保存退出。
(14)这时候,你就可以利用CocoPods下载AFNetworking类库了。还是在终端中的当前项目目录下,运行以下命令:
$ pod install 
(15)等待安装成功提示

(16)这个时候,会看到多了一个.xcworkspace工程,以后打开项目就用 cocoapodsSample.xcworkspace 打开,而不是之前的.xcodeproj文件。
(17)如果有一些包已经存在了,或者我们更改了Podfile里面的版本,可以使用以下命令更新:
$ pod update


备注:

(一)关于Podfile文件编辑时,第三方库版本号的各种写法:
pod ‘AFNetworking’      //不显式指定依赖库版本,表示每次都获取最新版本
pod ‘AFNetworking’,  ‘2.0//只使用2.0版本
pod ‘AFNetworking’, ‘>2.0//使用高于2.0的版本
pod ‘AFNetworking’, ‘>=2.0//使用大于或等于2.0的版本
pod ‘AFNetworking’, ‘<2.0//使用小于2.0的版本
pod ‘AFNetworking’, ‘<=2.0//使用小于或等于2.0的版本
pod ‘AFNetworking’, ‘~>0.1.2//使用大于等于0.1.2但小于0.2的版本,相当于>=0.1.2并且<0.2.0
pod ‘AFNetworking’, ‘~>0.1//使用大于等于0.1但小于1.0的版本
pod ‘AFNetworking’, ‘~>0//高于0的版本,写这个限制和什么都不写是一个效果,都表示使用最新版本
(二)Ruby的安装版本和默认设置的版本一定要对应

(三)使用CocoaPods来添加第三方类库,无论是执行pod install还是pod update都卡在了Analyzing dependencies不动

原因在于当执行以上两个命令的时候会升级CocoaPods的spec仓库,加一个参数可以省略这一步,然后速度就会提升不少。加参数的命令如下:


$ pod install --verbose --no-repo-update

$ pod update --verbose --no-repo-update


(四)往Xcode上安装插件管理器的方法     


(1)登录下面的网站


(2)安装插件管理器:终端执行如下命令


//删除插件管理器:终端执行如下命令

$ rm -rf ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/Alcatraz.xcplugin
阅读更多
版权声明:喜欢就分享啊 https://blog.csdn.net/sudons/article/details/52368328
文章标签: Mac Xcode Cocoapods
个人分类: 开发工具
上一篇如何在Mac OS X上安装 Ruby运行环境
下一篇Git使用Gitignore建立项目过滤规则
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭