数论--Pairs Forming LCM(素因子分解)

I - Pairs Forming LCM

Find the result of the following code:

long long pairsFormLCM( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
       
 for( int j = i; j <= n; j++ )
           
if( lcm(i, j) == n ) res++; // lcm means least common multiple
   
 return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2


首先需要知道数论的一些定理如:

唯一分解定理:任何一个数n=p1^e1*p2^e2*……*pk^ek

且设a,b为n的两个因子,则

a=p1 ^ a1 * p2 ^ a2 *..........*pn ^ an

b=p1 ^ b1 * p2 ^ b2 *..........*pn ^ bn

lcm(a,b)=p1^max(a1,b1)*p2^max(a2,b2)*……*pn^max(an,bn);

(lcm只需要将max改成min即可);

则若a,b的最小公倍数等于n,max(a1,b1)==e1,max(a2,b2)==e2,……,max(an,bn)==en

若ai==ei,bi则有0—ei,ei+1种可能,bi==ei同理。又因为ai==ei且bi==ei只有一种可能,

所以有2*ei+1种可能;除了 (n, n) 所有的情况都出现了两次  那么满足a<=b的有 (2*ei + 1)) / 2 + 1 个。

则可直接打出质数表,然后分解n的素因子,然后求出2*ei+1的乘积,最终将(ans-1)/2+1即可。


#include<stdio.h>
#include <algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#include<algorithm>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
bool vis[10000005];
int prime[1000000],cot;

void primeall()
{
    memset(vis,0,sizeof(vis));

    cot=0;
    for(int i=2;i<=10000005;i++)
        if(!vis[i])
        {
            prime[++cot]=i;
            for(int j=i+i;j<=10000005;j+=i)
                vis[j]=1;
        }
}

int main()
{
    int t;
    primeall();
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        ll n;
        scanf("%lld",&n);

        ll ans=1;
        for(int i=1;i<=cot && prime[i]*prime[i]<=n;i++)
        {
            int numb=0;
            while(n%prime[i]==0)
            {
                numb++;
                n/=prime[i];
            }
            ans*=(2*numb+1);
        }

        if(n>1)
            ans*=3;

        printf("Case %d: %lld\n",k,(ans-1)/2+1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值