顺序表应用6:有序顺序表查询

Problem Description

顺序表内按照由小到大的次序存放着n个互不相同的整数,任意输入一个整数,判断该整数在顺序表中是否存在。如果在顺序表中存在该整数,输出其在表中的序号;否则输出“No Found!"。

Input

 第一行输入整数n (1 <= n <= 100000),表示顺序表的元素个数; 第二行依次输入n个各不相同的有序非负整数,代表表里的元素; 第三行输入整数t (1 <= t <= 100000),代表要查询的次数; 第四行依次输入t个非负整数,代表每次要查询的数值。

保证所有输入的数都在 int 范围内。

Output

 输出t行,代表t次查询的结果,如果找到在本行输出该元素在表中的位置,否则本行输出No Found!

Example Input
10
1 22 33 55 63 70 74 79 80 87
4
55 10 2 87
Example Output
4
No Found!
No Found!
10
Hint
Author
      

 
#include <stdio.h>
#include <stdlib.h>
#define Max 201000
using namespace std;
typedef int elemtype;
int len;
typedef struct
{
    elemtype *elem;
    int listsize;
    int length;
}List;
void creat(List &L, int len)
{
    L.elem = new elemtype[Max];
    L.length = len;
    L.listsize = Max;
}

void output(List &L)
{
    int i;
    for(i = 0; i < L.length - 1; i++)
    {
        printf("%d ", L.elem[i]);
    }
    printf("%d\n", L.elem[L.length - 1]);
}
void input(List &L)
{
    int i;
    for(i = 1; i <= L.length; i++)
    {
        scanf("%d", &L.elem[i]);
    }

}
int locate(List &L, int low, int high, int key)
{
    int mid;
    if(low <= high)
    {
        mid = (low + high) / 2;
        if(L.elem[mid] == key)return mid;
        else if(L.elem[mid] > key)return locate(L, low, mid - 1, key);
        else return locate(L, mid + 1, high, key);
    }
    else return -1;
}
int main()
{
    List L;
    int n, t, key, ans;
    scanf("%d", &n);
    creat(L, n);
    input(L);
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &key);
        ans = locate(L, 1, n, key);
        if(ans == -1)printf("No Found!\n");
        else printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值