数据结构实验之栈与队列一:进制转换

Problem Description

输入一个十进制非负整数,将其转换成对应的 R (2 <= R <= 9) 进制数,并输出。

Input

第一行输入需要转换的十进制非负整数;
第二行输入 R。

Output

输出转换所得的 R 进制数。

Example Input
1279
8
Example Output
2377
Hint
Author

 

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#define Stack_size 100
#define Stackincreament 10
using namespace std;
typedef struct
{
    int *base;
    int top;
    int stacksize;
} sqstack;
void initstack(sqstack &la)
{
    la.base = (int *)malloc(Stack_size*sizeof(int));
    la.stacksize = Stack_size;
    if(!la.base)exit(0);
    la.top = 0;
}
void push(sqstack &L, int e)
{
    if(L.top >= L.stacksize)
    {
        L.base = (int *)realloc(L.base, (Stack_size + Stackincreament)*sizeof(int));
        if(!L.base)exit(0);
        L.stacksize+=Stackincreament;
    }
    L.base[L.top++] = e;
}
void pop(sqstack &l, int &e)
{
    if(l.top == 0)return ;
    e =l.base[--l.top];
}
void trans(int x, int n, sqstack &s)
{
    int e;
    while(x != 0)
    {
        e = x % n;
        x /= n;
        push(s, e);
    }
    while(s.top != 0)
    {
        pop(s, e);
        cout<<e;
    }
    cout<<endl;
}
int main()
{
    sqstack m;
    int x, n;
    cin>>x>>n;
    if(x == 0)cout<<0<<endl;
    else
    {
        initstack(m);
        trans(x, n, m);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值