pat 1018

1018. Public Bike Management (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
 
 
//有两个测试点通不过
#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;

#define INF 1 << 30

int Cmax, n, Sp, m;

int map[510][510];
int bike[510], path[510], dist[510], cost[510], vis[510]; 
vector<int> Q;

int abs(int t)
{
	if(t < 0)
		t = -t;
	return t;
}

void dij()
{
	int i, j;

	for(i = 0; i <= n; i++)
		dist[i] = INF;

	dist[0] = 0;
	cost[0] = 0;

	for(i = 0; i <= n; i++)
	{
		int min = INF, index = -1;
		
		for(j = 0; j <= n; j++)
		{
			if(vis[j] == 0 && dist[j] < min)
			{
				min = dist[j];
				index = j;
			}
		}

		if(min == INF || index == Sp) return;

		vis[index] = 1;

		for(j = 0; j <= n; j++)
		{
			if(vis[j] == 0)
			{
				int tmp = dist[index] + map[index][j];

				if(tmp < dist[j])
				{
					dist[j] = tmp;
					cost[j] = cost[index] + bike[j] - Cmax/2; //从PBMC到站点j需要sent的bike,如果为整数表示需要带回去,负数的绝对值表示需要sent的amounts
					path[j] = index;
				}
				else if(tmp == dist[j])
				{
					int tt = cost[index] + bike[j] - Cmax/2; //从站点index到j需要带回去或需要发送的数量
					if(tt > 0 && cost[j] > 0)
					{
						if(tt < cost[j])
							cost[j] = tt;
					}
					else if(tt < 0 && cost[j] < 0)
					{
						if(tt > cost[j])
							cost[j] = tt;
					}
					else
					{
						cost[j] = abs(cost[j]) < abs(tt) ? cost[j] : tt;
					}
				}
			}
		}
	}
}

int main()
{
	int i, j;

	while(scanf("%d%d%d%d", &Cmax, &n, &Sp, &m) != EOF)
	{
		int a, b, l;

		for(i = 0; i <= n; i++)
			for(j = 0; j <= n; j++)
				map[i][j] = map[j][i] = INF;

		for(i = 1; i <= n; i++)
		{
			scanf("%d", &bike[i]);
		}

		for(i = 1; i <= m; i++)
		{
			scanf("%d%d%d", &a, &b, &l);
			map[a][b] = map[b][a] = l;
		}

		memset(vis, 0, sizeof(vis));

		dij();

		Q.clear();
		
		int dis = Sp;

		while(Sp != 0)
		{
			Q.push_back(Sp);
			Sp = path[Sp];
		}

		Q.push_back(0);


		if(cost[dis] < 0)
		{
			printf("%d ", -cost[dis]);

			for(i = Q.size() - 1; i >= 0; i--)
			{
				if(i != 0)
					printf("%d->", Q[i]);
				else
					printf("%d ", Q[0]);
			}

			printf("0\n");
		}
		else
		{//如果自行车需要带回去
			printf("0 ");
			
			for(i = Q.size() - 1; i >= 0; i--)
			{
				if(i != 0)
					printf("%d->", Q[i]);
				else
					printf("%d ", Q[0]);
			}

			printf("%d\n", cost[dis]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
function copy-data([int]$startrow, [int]$startcol, [int]$endrow, [int]$endcol, [string]$pat, [string]$file, [int]$sheetfrom, [int]$sheetto) { $excel = New-Object -ComObject Excel.Application $excel.Visible = $false $wb = $excel.Workbooks.Open($file) $wsfrom = $wb.Sheets.Item($sheetfrom) $wsto = $wb.Sheets.Item($sheetto) $sr = $wsfrom.Range($wsfrom.Cells.Item($startrow, $startcol), $wsfrom.Cells.Item($endrow, $endcol)) $fc = $sr.Find($pat) if ($fc -ne $null) { $rown = $fc.Row $dsr = $wsto.Range($wsto.Cells.Item($rown, $startcol), $wsto.Cells.Item($rown + ($endrow - $startrow), $endcol)) $dsr = $dsr.Resize($sr.Rows.Count, $sr.Columns.Count) $sr.Copy() $dsr.PasteSpecial(-4104) } $excel.DisplayAlerts = $false $wb.Close($true) [Runtime.Interopservices.Marshal]::ReleaseComObject($excel) | Out-Null } $path = $PWD.Path $file = "$path\a.xlsx" # 将sheet1中第1行到第4行、第2列到第9列的数据复制到sheet2中 copy-data -startrow 1 -startcol 2 -endrow 4 -endcol 9 -pat 1009 -file $file -sheetfrom 1 -sheetto 2 # 将sheet1中第6行到第8行、第2列到第9列的数据复制到sheet2中 copy-data -startrow 6 -startcol 2 -endrow 8 -endcol 9 -pat 1018 -file $file -sheetfrom 1 -sheetto 2 # 将sheet1中第10行到第11行、第2列到第9列的数据复制到sheet2中 copy-data -startrow 10 -startcol 2 -endrow 11 -endcol 9 -pat 1023 -file $file -sheetfrom 1 -sheetto 2 这个是搜索sheet1中关键词吗,我现在要搜索sheet2中关键词 得到行信息后再把sheet1指定内容复制到sheet2指定区域,怎么修改呢
05-19

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值