pat 1064

1064. Complete Binary Search Tree (30)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
 
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <queue>
using namespace std;

typedef struct Tree
{
	Tree *lchild;
	Tree *rchild;
	int data;
} Tree, *Llink;

Tree tree[1010];

int n, loc = 0;
int order[1010], lvOd[1010], sum;
queue<Llink> Q;

Tree *creat()
{
	tree[loc].lchild = tree[loc].rchild = NULL;
	return &tree[loc++];
}

//建立完全二叉搜索树,关键是每次递归时找到根结点的位置,和左子树结点的个数和右子树结点的个数
Tree *build(int s, int e)
{
	Tree *T = NULL;

	if(s > e)
		return T;

	int num = e - s + 1, i = 0, level, remain;

	while(num >= (int)pow(2.0, i))
	{
		num -= pow(2.0, i);
		i++;
	}

	level = i;
	remain = num;//最后一层结点的个数

	int countl =(e - s - remain) / 2;
	int countr = countl; 

	if( (int)pow(2.0, level) / 2 >= num)
		countl += num;
	else
	{
		countl += (int)pow(2.0, level) / 2; //左子树结点的个数
		countr += num - (int)pow(2.0, level) / 2; //右子树结点的个数
	}

	T = creat();
	T->data = order[s+countl];  //根结点的位置

	T->lchild = build(s, s + countl - 1);


	T->rchild = build(s + countl + 1, e);

	return T;
}

void levelTraversal()
{
	int i;
	Tree *T = NULL;

	while(!Q.empty())
	{
		T = Q.front();
		Q.pop();
		lvOd[sum++] = T->data;

		if(T->lchild != NULL)
			Q.push(T->lchild);
		if(T->rchild != NULL)
			Q.push(T->rchild);
	}
}

int main()
{
	int i, j;

	while(scanf("%d", &n) != EOF)
	{
		Tree *T = NULL;

		for(i = 0; i < n; i++)
		{
			scanf("%d", &order[i]);
		}

		sort(order, order + n);

		T = build(0, n-1);
		
		while(!Q.empty())
			Q.pop();

		sum = 0;
		Q.push(T);
		levelTraversal();
	
		for(i = 0; i < sum; i++)
		{
			if(i != sum - 1)
				printf("%d ", lvOd[i]);
			else
				printf("%d\n", lvOd[i]);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值