pat 1090 Highest Price in Supply Chain

1090. Highest Price in Supply Chain (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:

1.85 2

#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
using namespace std;

#define MAX 100010

int n, maxt = 0, cnt = 0;
double P, r, ansPrice;
int tree[MAX], level[MAX];
vector<int> chl[MAX];

void dfs(int index, int high, double price)
{
	int i;
	if(high >= maxt)
	{
		if(high > maxt) maxt = high, cnt = 1, ansPrice = price;

		else if(high == maxt) cnt++, ansPrice = price;
	}

	for(i = 0; i < chl[index].size(); i++)
	{
		int t = chl[index][i];
		level[t] = high + 1;
		double pp = price * (1 + r/100.0);
		dfs(t, level[t], pp);
		
	}
}
int main()
{
	int i, tmp, root;

	while(scanf("%d %lf %lf", &n, &P, &r) != EOF)
	{
		memset(level, 0, sizeof(level));
		
		for(i = 0; i < n; i++)
			tree[i] = -1;

		for(i = 0; i < n; i++)
		{
			scanf("%d", &tmp);

			tree[i] = tmp;
			chl[tmp].push_back(i);

			if(tmp == -1)
				root = i;
		}
		
		level[root] = 1;

		dfs(root, 1, P);
		
		printf("%.2lf %d\n", ansPrice, cnt);
	}
	return 0;	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值