1090 Highest Price in Supply Chain(25 分)(C++)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

树的遍历:求最深层的level和节点个数,BFS和DFS均可

BFS(层次遍历)

#include <iostream>
#include <vector>
#include <cmath>
#include <queue>
using namespace std;
int n, root, maxlevel = -1, level, cnt = 0, last;
double ans,p,r;
std::vector<std::vector<int>> tree;
int main(){
    cin>>n>>p>>r;
    r = r*0.01 + 1; 
    tree.resize(n);
    for(int i = 0; i < n; i++){
        int temp;
        scanf("%d",&temp);
        if(temp == -1)
            last = root = i;
        else
            tree[temp].push_back(i);
    }
    queue<int>q;
    q.push(root);
    while(!q.empty()){
        int temp = q.front();
        q.pop();
        if(tree[temp].size() == 0){
            if(level > maxlevel){
                cnt = 1;
                ans = pow(r,level)*p;
                maxlevel = level;
            }
            else if(level == maxlevel)
                cnt++;
        }
        for(int i = 0; i < tree[temp].size(); i++)
            q.push(tree[temp][i]);
        if(last == temp){
            last = q.back();
            level ++;
        }
    }
    printf("%.02f %d",ans,cnt);
}

DFS(先根遍历)

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int n,root,maxlevel = -1,cnt = 0;
double ans,p,r;
std::vector<std::vector<int>> tree;
void dfs(int index,int level){
    if(tree[index].size() == 0){
        if(level > maxlevel){
            cnt = 1;
            ans = pow(r,level)*p;
            maxlevel = level;
        }
        else if(level == maxlevel)
            cnt++;
        return;
    }
    for(int i = 0; i < tree[index].size(); i++)
        dfs(tree[index][i],level+1);
}
int main(){
    cin>>n>>p>>r;
    r = r*0.01 + 1; 
    tree.resize(n);
    for(int i = 0; i < n; i++){
        int temp;
        scanf("%d",&temp);
        if(temp == -1)
            root = i;
        else
            tree[temp].push_back(i);
    }
    dfs(root, 0);
    printf("%.02f %d",ans,cnt);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是一个简单的 C++ 代码示例,用于记录斗地主游戏的历史最高记录: ```cpp #include <iostream> #include <fstream> #include <string> using namespace std; int main() { int score; string line; int highest_score = 0; // 打开文件,如果文件不存在则创建新文件 ifstream file("landlord_scores.txt"); if (file.is_open()) { // 如果文件存在,则读取文件中的历史最高记录 while (getline(file, line)) { if (line.find("最高得: ") != string::npos) { int score_in_file = stoi(line.substr(6)); highest_score = max(highest_score, score_in_file); } } file.close(); } // 进行游戏,获取当前得 score // 如果当前得高于历史最高记录,则更新记录并写入文件 if (score > highest_score) { ofstream file("landlord_scores.txt"); if (file.is_open()) { file << "最高得: " << score << endl; file.close(); } } return 0; } ``` 在这个示例中,我们使用了 C++ 标准库中的 `fstream` 类来打开文件,并通过 `is_open()` 方法检查文件是否成功打开。然后我们使用 `getline()` 方法逐行读取文件内容,并通过 `find()` 方法在每一行中查找是否包含历史最高记录。如果找到了历史最高记录,则使用 `substr()` 方法从字符串中截取得记录,并使用 `stoi()` 方法将其转换为整数。最后我们使用 `max()` 函数取出历史最高记录。接着我们进行游戏并获取当前得 `score`,如果当前得高于历史最高记录,则使用 `"ofstream"` 模式打开文件并将新的最高得记录写入文件中。 请注意,在实际应用中,您需要根据具体需求适当修改代码,并添加错误处理和异常处理等必要的代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值