pat 1080 Graduate Admission

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;

struct Stu
{
	double GE, GI;
	double avg;
	int stuID;
	vector<int> choice;
};

bool cmp(const Stu &stu1, const Stu &stu2) {
	if(stu1.avg != stu2.avg) {
		return stu1.avg > stu2.avg;
	} else {
		return stu1.GE > stu2.GE;
	}
}
vector<Stu> vec;
vector<int> schoolQuta;


int main() {
	int N, M, K;
	scanf("%d %d %d", &N, &M, &K);
	double GE, GI;
	map<int, int> rank;
	vector<int> schoolUsedQuta(M, 0);
	vector<vector<int> > schoolAdmitStu(M);

	for (int i = 0; i < M; ++i)
	{
		int x;
		scanf("%d", &x);
		schoolQuta.push_back(x);
	}

	for (int i = 0; i < N; ++i)
	{
		Stu stu;
		scanf("%lf %lf", &GE, &GI);
		stu.GE = GE;
		stu.GI = GI;
		stu.avg = (GE+GI)/2;
		stu.stuID = i;
		for (int j = 0; j < K; ++j)
		{
			int x;
			scanf("%d", &x);
			stu.choice.push_back(x);
		}
		vec.push_back(stu);
	}

	sort(vec.begin(), vec.end(), cmp);

	for (int i = 0; i < N; ++i)
	{
		rank[vec[i].stuID]=i;
	}

	for (int i = 0; i < N; ++i)
	{
		Stu stu = vec[i];

		for (int j = 0; j < K; ++j)
		{
			if(schoolUsedQuta[stu.choice[j]] < schoolQuta[stu.choice[j]]) {
				schoolUsedQuta[stu.choice[j]]++;
				schoolAdmitStu[stu.choice[j]].push_back(vec[i].stuID);
				break;
			} else {
				int k = stu.choice[j];
				int lastId = schoolAdmitStu[k][schoolAdmitStu[k].size()-1];
				if(vec[rank[lastId]].avg == stu.avg && vec[rank[lastId]].GE==stu.GE) {
					schoolAdmitStu[k].push_back(stu.stuID);
					schoolUsedQuta[k]++;
					break;
				}
			}
		}
	}

	for (int i = 0; i < M; ++i)
	{
		sort(schoolAdmitStu[i].begin(), schoolAdmitStu[i].end());
	}

	for (int i = 0; i < M; ++i)
	{
		for (int j = 0; j < schoolAdmitStu[i].size(); ++j)
		{
			if(j == 0) printf("%d", schoolAdmitStu[i][j]);

			else printf(" %d", schoolAdmitStu[i][j]);
		}
		printf("\n");
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于Kubernetes的k3d集群可以使用admission webhook来验证和修改资源对象。下面是一个简单的k3d admission webhook的演示: 1. 创建一个名为`validating-webhook.yaml`的文件,内容如下: ```yaml apiVersion: admissionregistration.k8s.io/v1 kind: ValidatingWebhookConfiguration metadata: name: example.k3d.local webhooks: - name: example.k3d.local clientConfig: service: name: example.k3d.local namespace: default path: "/validate" caBundle: "" rules: - apiGroups: - "" - "extensions" - "apps" apiVersions: - "v1" - "v1beta1" - "v1beta2" operations: - CREATE - UPDATE resources: - "pods" - "deployments" - "replicasets" failurePolicy: Fail sideEffects: None admissionReviewVersions: - v1 - v1beta1 ``` 这个文件定义了一个名为`example.k3d.local`的验证webhook,它将验证和修改`pods`、`deployments`和`replicasets`资源对象。 2. 创建一个名为`deployment.yaml`的文件,内容如下: ```yaml apiVersion: apps/v1 kind: Deployment metadata: name: nginx-deployment spec: replicas: 3 selector: matchLabels: app: nginx template: metadata: labels: app: nginx spec: containers: - name: nginx image: nginx:1.14.2 ports: - containerPort: 80 ``` 这个文件定义了一个名为`nginx-deployment`的Deployment对象,它将创建3个Nginx容器。 3. 创建一个名为`Dockerfile`的文件,内容如下: ```dockerfile FROM python:3.7-alpine RUN pip install flask COPY app.py /app.py CMD ["python", "/app.py"] ``` 这个文件定义了一个基于Python 3.7的Docker镜像,它将安装Flask并运行一个名为`app.py`的应用程序。 4. 创建一个名为`app.py`的文件,内容如下: ```python from flask import Flask, request, jsonify import json app = Flask(__name__) @app.route('/validate', methods=['POST']) def validate(): admission_review = request.get_json() resource = admission_review['request']['object'] if resource['kind'] == 'Deployment': if resource['metadata']['name'] != 'nginx-deployment': return jsonify({'response': {'allowed': False, 'status': {'reason': 'Name is not nginx-deployment'}}}) return jsonify({'response': {'allowed': True}}) if __name__ == '__main__': app.run(debug=True, host='0.0.0.0', port=8080) ``` 这个文件定义了一个Flask应用程序,它将验证`Deployment`对象的名称是否为`nginx-deployment`。 5. 构建Docker镜像: ```shell docker build -t k3d-admission . ``` 6. 创建一个名为`k3d-cluster.yaml`的文件,内容如下: ```yaml apiVersion: k3d.io/v1alpha2 kind: Cluster nodes: 1 name: k3d-admission ports: - port: 8080:8080 protocol: TCP image: rancher/k3s:v1.20.4-k3s1 wait: true ``` 这个文件定义了一个名为`k3d-admission`的k3d集群,它将暴露端口8080以便验证webhook服务可以访问。 7. 创建k3d集群: ```shell k3d cluster create -f k3d-cluster.yaml ``` 8. 部署验证webhook服务: ```shell kubectl apply -f validating-webhook.yaml kubectl apply -f deployment.yaml ``` 9. 验证验证webhook服务是否工作: ```shell kubectl create deployment nginx --image=nginx:1.14.2 ``` 这个命令将创建一个名为`nginx`的Deployment对象,但是由于它的名称不是`nginx-deployment`,验证webhook服务将拒绝它的创建。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值