FZU 2039 二分图

Description

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.

Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

Sample Input

12 2 21 22 1

Sample Output

Case 1: 2
题意:
N个人M个宠物e个条件,每个条件告诉你哪些人不喜欢哪些宠物,每个人最多买一条宠物,问最多能有多少人买到宠物?
解题思路:
二分图,寻找增广路,匈牙利算法。
代码:
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<vector>
using namespace std;
const int maxn=2*105;
const int maxm=2*105*105;
const int INF=0x3f3f3f3f;
int fir[maxn];
int u[maxm],v[maxm],nex[maxm];
int e_max;
int match[maxn];
bool check[maxn];
int g[maxn][maxn];
int ans;
inline void init()
{
         memset(fir, -1, sizeof fir);
         e_max = 0;
}
inline void add_edge(int s, int t)
 {
        int e = e_max++;
        u[e] = s;
        v[e] = t;
        nex[e] = fir[u[e]];
        fir[u[e]] = e;
}
int n,m,e;
bool dfs(int u)
{
        for(int e=fir[u];~e;e=nex[e])
        {
                int vv=v[e];
                if(!check[vv])//访问未访问的节点
                {
                        check[vv]=1;
                        if(match[vv]==-1||dfs(match[vv]))//找到增广,交换这条路的匹配方式,标记。
                        {
                                match[vv]=u;
                                match[u]=vv;
                                return 1;
                        }
                }
        }
        return 0;
}
int  hungary()
{
        ans=0;
        memset(match,-1,sizeof match);
        for(int i=1;i<=n;i++)
        {
                if(match[i]==-1)
                {
                        memset(check,0,sizeof check);//每次初始化check。
                        if(dfs(i))                   //存在增广路(i节点存在匹配)
                                ans++;
                }
        }
}
int main()
{
        int T;
        cin>>T;
        int a,b;
        int w=0;
        while(T--)
        {
                init();
                memset(g,1,sizeof g);
                scanf("%d%d%d",&n,&m,&e);
                for(int i=0;i<e;i++)
                {
                        scanf("%d%d",&a,&b);
                        g[a][b+n]=0;           //把宠物编号为m+1到m+n;
                        g[b+n][a]=0;

                }
                for(int i=1;i<=n;i++)
                {
                        for(int j=n+1;j<=m+n;j++)
                        {
                                if(g[i][j])
                                {
                                        add_edge(i,j);
                                        add_edge(j,i);
                                }
                        }
                }
                hungary();
                printf("Case %d: %d\n",++w,ans);
        }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值