杭电ACM 2031,2057 进制转化问题


HDU 2031

进制转换

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41164    Accepted Submission(s): 22573


Problem Description
输入一个十进制数N,将它转换成R进制数输出。
 

Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
 

Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
 

Sample Input
  
  
7 2 23 12 -4 3
 

Sample Output
  
  
111 1B -11
 
解题思路运用除r取余的方法进行进制转化,不过这里要注意负数的问题

我的代码:

#include<iostream>
#include<iomanip>
#include<math.h>
#include<deque>
using namespace std;
int main()
{
    deque<int> de;
    int n,m,r,f;
    while(cin>>m>>r)
    {  
        n = abs(m);
        de.clear();
        while(n != 0)
        {
            f=n%r;
            de.push_front(f);
            n/=r;
        }
        if(m < 0) cout<<"-";
        for(int i = 0;i <= de.size() - 1;i++)
        {
            if(de[i] >= 10)
                printf("%X",de[i])  ;            //cout<<setiosflags(ios::uppercase)<<hex<<de[i];
            else
                cout<<de[i];
        }
        cout<<endl;
    }
    return 0;
}


HDU 2057

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22572    Accepted Submission(s): 9787


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
  
  
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
  
  
0 2C 11 -2C -90

我的代码:

#include<stdio.h>
void main()
{
    __int64 a,b,sum;
    while(scanf("%I64X%I64X",&a,&b) != EOF)
    {
        sum = a + b;
        if(sum >= 0)
            printf("%I64X\n",sum);
        else
            printf("-%I64X\n",-sum);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值