POJ 1258 Agri-Net prim算法

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39172 Accepted: 15875

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

USACO 102

数组的意思是:比如点(1,2)=4,表示点1跟点2的距离是4.,所以点(2,1)也是4.这样一个矩阵表明点1可以达到其余所有点。所以在下面程序中第一次给low赋值的时候就是i=1到i=n;

prim算法:

#include<iostream>
#include<cstring>
#include<cstdio>
#define  maxn 110
#define maxint 100010
using namespace std;
int map[maxn][maxn];
int vis[maxn];
int low[maxn];//用来记录最短路程
int n;
int prim()
{
    int pos,i,j,min;
    int res=0;
    pos=1;
    vis[1]=1;
    for(i=1;i<=n;i++)
       if(i!=pos)  low[i]=map[pos][i];     //从第一个点开始,第一次给LOW赋值,便于下面从中选出最小的一个,作为第二个要访问的点。

    for(i=1;i<n;i++)     //注意此处不能I等于N,不然会多算一次。
      {
          min=maxint;
             for(j=1;j<=n;j++)
              if(vis[j]==0&&min>low[j])
                  {
                   min=low[j];
                   pos=j;
                  }   //从LOW中选出最小的距离,下次就从该点向其他点扩散。

                  res+=min;
                  vis[pos]=1;//已经访问过了就表示已经可以到达该点,以后就不用联通该点。
                 // cout<<pos<<endl;
           for(j=1;j<=n;j++)
              {
                  if(vis[j]==0&&low[j]>map[pos][j])
                       low[j]=map[pos][j];
              }//例如第一次执行到此处,将由点1到其他点的距离和点POS到其他点未访问的点的距离相比,如果POS到的距离小,就赋到low数组,下次比较就从LOW中选出最小的值,作为第三个访问的点,可能是从POS到该点或者从点一到该点,不管怎么样,该点都是作为第三个访问的点的。

      }

    return res;
}


int main()
{
     int ans;
    while(cin>>n)
       {
           for(int i=1;i<=n;i++)
              for(int j=1;j<=n;j++)
                // cin>>map[i][j];
                scanf("%d",&map[i][j]);//用scanf比cin快了100多ms,可以试试。
                 memset(vis,0,sizeof(vis));//输入数据有多组,所以得每次初始化一下。
                 ans=prim();
                 //cout<<ans<<endl;
                 printf("%d\n",ans);




       }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值