模运算

  • Description

给定整数a,b,n,要求计算(a^b)mod n

  • Input

多组数据,每组数据一行,为三个用空格隔开的整数a,b,n

1<=a<=5000,0<=b<=10^8,1<=n<=5000000

  • Output

每组数据输出一行,为所求值

  • Sample Input

2 3 5
2 2 4

  • Sample Output

3
0

 #include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

__int64 a,b,c;

void solve()
{
    __int64 res=1;
    while(b)
    {
        if(b&1) res=res*a%c;
        a=a*a%c;
        b>>=1;
    }
    printf("%I64d\n",res);
}

int main()
{
    while(scanf("%I64d %I64d %I64d",&a,&b,&c)!=EOF)
    {
        solve();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值