hdu1865 1 sting(大数)

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3504    Accepted Submission(s): 1364


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt
 

Source


#include<stdio.h>
#include<string.h>
#define N 211
#define M 33
int ans[N][M],len[N];
void init()
{
	int i,l;
	memset(len,0,sizeof(len));
	memset(ans,0,sizeof(ans));
	len[1]=len[2]=1;
	ans[1][0]=1;
	ans[2][0]=2;
	for(i=3;i<=200;i++)
	{
		for(l=0;l<len[i-1];l++)
		{
			ans[i][l]+=ans[i-1][l]+ans[i-2][l];
			ans[i][l+1]+=ans[i][l]/1000000;
			ans[i][l]%=1000000;
		}
		len[i]=len[i-1];
		if(ans[i][len[i]]) len[i]++;
	}
}
int main()
{
	init();
	int T,L,l;
	char str[211];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s",str);
		L=strlen(str);
		printf("%d",ans[L][len[L]-1]);
		for(l=len[L]-2;l>=0;l--) printf("%06d",ans[L][l]);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值