HDU 1865 1sting(大数斐波那契数列,模拟加法)

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4306    Accepted Submission(s): 1634


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 


Author
z.jt
 


看懂题意以后,可以先推一下 111 和 1111的数量,不难推导出 111 的结果为 3 ,1111的结果为 4,因此可以得出,这道题是个递推题,递推公式就是斐波那契数列,但是,有一个难点就是要推出前 200 项的  ,这样  long long  的范围也肯定会超,所以就需要用到大数加法了


用二维数组,一维作为标记,二维作为储存


附上代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>

using namespace std;

int main()
{
	int s[250][50] = {0};         //  这里面我定义的数字为最长为50位,害怕不够的可以定义的大些,不过第 200 项的 数位是22 位
	s[1][0] = 1;
	s[2][0] = 2;
	s[3][0] = 3;
	for(int j = 4;j < 201;j++)
	{
		int jin = 0;
		for(int i = 0;i < 50;i++)
        {
            s[j][i] = s[j - 1][i] + s[j - 2][i] + jin;
            jin = 0;
            if(s[j][i] > 9 && i < 49)
            {
                jin = s[j][i]/10;
                s[j][i] = s[j][i]%10;
            }
        }
	}
	int t;
	cin >> t;
	while(t--)
	{
		char str[250];
		cin >> str;
		int flag = 0;
		for(int i = 49;i >= 0;i--)
		{
			if(s[strlen(str)][i] == 0 && flag == 0)           //  除去前面的 0
			{
				continue;
			}
			flag = 1;
			cout << s[strlen(str)][i];
		}
		cout << endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值