hdu 2818 Building Block(并查集)

Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3315    Accepted Submission(s): 991


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2
 

Source


#include<stdio.h>
#include<iostream>
using namespace std;
int father[30005];
int high[30005];//以该点为根结点的最大高度 
int low[30005];//该集合中该点下面的高度 
int find(int x)
{
	if(father[x]==x)
	return x;
	int fx=find(father[x]);
	low[x]=low[father[x]]+low[x];
	return father[x]=fx;
}
void init()
{
	int i;
	for(i=0;i<30005;i++)
	{
		father[i]=i;
		high[i]=1;
		low[i]=0;
	}
}
int main()
{
	int p;
	char c;
	scanf("%d",&p);
	getchar();
	init();
	while(p--)
	{
		int x,y;
		scanf("%c ",&c);
		if(c=='M')
		{
			scanf("%d %d",&x,&y);
			getchar();
			int px=find(x);
			int py=find(y);
			if(px==py)
			continue;
			father[px]=py;
			low[px]=high[py];
			high[py]=high[px]+high[py];
		}
		else if(c=='C')
		{
			//getchar();
			int k;
			scanf("%d",&k);
			getchar();
			find(k);
			printf("%d\n",low[k]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值