HDU 2818 Building Block 带权并查集

Building Block

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5966 Accepted Submission(s): 1853

Problem Description

John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1…N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.

Input

The first line contains integer P. Then P lines follow, each of which contain an operation describe above.

Output

Output the count for each C operations in one line.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

2009 Multi-University Training Contest 1 - Host by TJU

题意:
有n块砖和p次操作:
M x y:表示将编号为x所在的这一列砖移到编号为y在的那一列砖的上面,如果两块砖已经在同一列了,就跳过。
C x:表示询问编号为x的砖的下面有多少砖。

坑点:砖的编号实际为0~30000 - 1

分析:
还是关于一些集合合并的问题,只不过这次要询问下面有多少块砖。所以只是单纯的并查集是不够的。
我们用rk[x]表示编号为x的砖下面有多少块砖。将在上面的砖连到它下面的砖上。则路径压缩时合并:rk[x]+=rk[fa[x]];

对于需要合并的砖a、b:
不难发现,对于移动到上方的砖a,现在a所在的那一列的每一块砖的rk都需要加上siz[b],
//siz[i]表示i所在的这一列有多少块砖
可以直接在root a上加上siz[b],注意合并后siz的改变。

至于查询,可以再查找一下它现在的根,如果之前有根的改变,那么在查找的过程中就会将改变的值加上。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

inline int read(){
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9') {if(ch=='-') f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') {x=x*10+ch-'0';ch=getchar();}
    return x*f;
}

const int N = 30000 + 10;
int p;
int fa[N],rk[N],siz[N];

int find(int x){
    if(x==fa[x]) return fa[x];
    int d=find(fa[x]);
    rk[x]+=rk[fa[x]];
    return fa[x]=d;
}

void link(int x,int y){
    int fx=find(x),fy=find(y);
    if(fx==fy) return ;
    rk[fx]+=siz[fy];
    siz[fy]+=siz[fx];
    fa[fx]=fy;
}

int main(){
    p=read();
    for(register int i=0;i<=N-10;i++) siz[i]=1,fa[i]=i,rk[i]=0;
    for(register int j=1;j<=p;j++){
        char s[5];scanf("%s",s);
        if(s[0]=='M'){
            int x=read(),y=read();
            link(x,y);
        }
        else{
            int x=read();find(x);
            printf("%d\n",rk[x]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值