poj 2456 Aggressive cows(贪心+二分)

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6620 Accepted: 3327

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source


题意:农夫约翰建了一个有n间牛舍的小屋。牛舍排在一条线上,第i号牛对应xi的位置。但是他的c头牛对小屋不满意,因此常相互攻击。农夫为了防止牛之间的伤害,决定把每头牛放在离其他牛尽可能远的地方。
二分思路:最大化最近的两头牛之间的距离。
C(d):=可以安排的位置是的最近的两头牛的距离不小于d
求满足C(d)的最大的d,最近的距离小于d,也就是说所有牛之间的距离都不小于d
所以C(d)=可以安胖子牛的位置使得任意牛之间的距离都不小于d
贪心:
1,对牛的位置x进行排序
2,把第一头牛放在x0的牛舍
3,如果第i头牛放在x(j)的话,第i+1头就要放在x(j)+d<=x(k)的最小的x(k)中。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
int x[100005];
int n,c;
int binary(int mid)
{
	//int low,high;
	int i,sum,pos;
	//sum=0;
	pos=1;
	for(i=1;i<c;i++)
	{
		sum=0;
		while(sum<mid&&pos<n)
		{
			sum+=x[pos]-x[pos-1];
			pos++;
		}
		if(sum<mid) return 0;
	}
	return 1;
}
int bin()
{
	int low=0;
	int high=(x[n-1]-x[0])/(c-1);
	while(low<=high)
	{
		int mid=(low+high)/2;
		if(binary(mid))
		low=mid+1;
		else
		high=mid-1;
	}
	printf("%d\n",high);
}
int main()
{
	int i;
	scanf("%d%d",&n,&c);
	for(i=0;i<n;i++)
	{
		scanf("%d",&x[i]);
	}
	sort(x,x+n);
	bin();
	//printf("%d\n",high);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值