HDU - 1061 Rightmost Digit(二分快速幂板题)

Description

计算N^N%10,其中1<=N<=1,000,000,000。 输入的第一行n为用例,计算后序的n行结果。

Sample Input

2
3
4

Sample Output

7
6

Solution

二分快速幂板题。

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
LL binary_pow(LL a, LL b, LL m)
{
    LL ans = 1;
    a = a % m;
    while (b > 0)
    {
        if (b & 1) //等价b%2==1
            ans = ans * a % m;
        a = a * a % m; //令a平方后取模
        b >>= 1;       //等价b=b/2
    }
    return ans;
}
int main()
{
    // freopen("in.txt", "r", stdin);
    LL a, m = 10, n;
    while (~scanf("%lld", &n))
    {
        for (int i = 0; i < n; i++)
        {
            scanf("%lld", &a);
            printf("%lld\n", binary_pow(a, a, 1));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值