POJ1458 Common Subsequence (最长公共子序列)

这篇博客详细解析了如何使用动态规划解决POJ1458问题,探讨了最长公共子序列的计算方法,通过实例展示了算法的实现过程。
摘要由CSDN通过智能技术生成

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
 
题目大意:在两串字符串中,各删除个别字母,使两个字符串相同。求最长字符串的长度。
开辟一个二维数组进行动规,dp[i][j]表示第一个字符串的第i个及第二个字符串的第j个字符之前所能够构成的最长字串的长度。状态转移方程为:if (a[i]==b[j])dp[i][j]=dp[i-1][j-1]+1;else (dp[i][j]=max(dp[i-1][j]),dp[i][j-1]);
这道题特别要注意的是数组的初始条件。见代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int main()
{
    char a[205],b[205];
    int dp[205][205],i,j,ans,len1,len2,flag,p;
    while (cin>>a>>b)
    {
        flag=1;
        if (strcmp(a,"\0")==0||strcmp(b,"\0")==0)
        {
            ans=0;
            flag=0;
        }
        if (flag==0)
        {
            goto l1;
        }
        len1=strlen(a);
        len2=strlen(b);
        ans=0;
        memset(dp,0,sizeof(dp));
        for (i=0;i<=len1-1;i++)\\初始化
        {
            p=0;
            if (a[i]==b[0])
            {
                for (j=i;j<=len1-1;j++)
                {
                    dp[j][0]=1;
                }
                p=1;
            }
            if (p==1)
            {
                break;
            }
        }
        for (i=0;i<=len2-1;i++)
        {
            p=0;
            if (a[0]==b[i])
            {
                for (j=i;j<=len2-1;j++)
                {
                    dp[0][j]=1;
                }
                p=1;
            }
            if (p==1)
            {
                break;
            }
        }
        for (i=1;i<=len1-1;i++)
        {
            for (j=1;j<=len2-1;j++)
            {
                if (a[i]==b[j])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                    if (dp[i][j]>ans)
                    {
                        ans=dp[i][j];
                    }
                }
                else
                {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
       l1: cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值