USACO 4.2 job processing

A factory is running a production line that requires two operations to be performed on each job: first operation "A" then operation "B". Only a certain number of machines are capable of performing each operation.


Figure 1 shows the organization of the production line that works as follows. A type "A" machine takes a job from the input container, performs operation "A" and puts the job into the intermediate container. A type "B" machine takes a job from the intermediate container, performs operation "B" and puts the job into the output container. All machines can work in parallel and independently of each other, and the size of each container is unlimited. The machines have different performance characteristics, a given machine requires a given processing time for its operation.

Give the earliest time operation "A" can be completed for all N jobs provided that the jobs are available at time 0. Compute the minimal amount of time that is necessary to perform both operations (successively, of course) on all N jobs.

PROGRAM NAME: job

INPUT FORMAT

Line 1:Three space-separated integers:
  • N, the number of jobs (1<=N<=1000).
  • M1, the number of type "A" machines (1<=M1<=30)
  • M2, the number of type "B" machines (1<=M2<=30)
Line 2..etc:M1 integers that are the job processing times of each type "A" machine (1..20) followed by M2 integers, the job processing times of each type "B" machine (1..20).

SAMPLE INPUT (file job.in)

5 2 3
1 1 3 1 4

OUTPUT FORMAT

A single line containing two integers: the minimum time to perform all "A" tasks and the minimum time to perform all "B" tasks (which require "A" tasks, of course).

SAMPLE OUTPUT (file job.out)

3 5

关于求A的最短时间,最先想到的是DP,而总时间的最小值该怎么求一直没有好的思路,感觉这个问题和4.1的fence rail 有些相似,最后只好搜索加剪枝,前6个点能过,第7个点超时,后来听ZZY说这个可以用贪心,再上网看了些解题报告,终于豁然开朗。在此推荐一个解释得比较清晰的博客:http://magicalcode.blogbus.com/logs/37193487.html


下面是我的代码:

#include<cstdio>
#include<algorithm>
#define oo 1000000
using namespace std;

FILE *in,*out;
int n,a,b,ta[30],tb[30],cost[30],tableA[10001],tableB[10001];

void greedy(int *arr,int len,int *rec);
bool cmp(const int &a,const int & b);

int main()
{
    in=fopen("job.in","r");
    out=fopen("job.out","w");
    fscanf(in,"%d%d%d",&n,&a,&b);
    for(int i=0;i<a;i++) fscanf(in,"%d",&ta[i]);
    for(int i=0;i<b;i++) fscanf(in,"%d",&tb[i]);
    greedy(ta,a,tableA);
    greedy(tb,b,tableB);
    int max=0;
    sort(tableA,tableA+n);
    fprintf(out,"%d ",tableA[n-1]);
    sort(tableB,tableB+n,cmp);
    for(int i=0;i<n;i++) if(max<(tableA[i]+tableB[i])) max=tableA[i]+tableB[i];
    fprintf(out,"%d\n",max);
    fclose(in);
    fclose(out);
    return 0;
}

void greedy(int *arr,int len,int *rec)
{
     for(int i=0;i<len;i++) cost[i]=0;
     for(int i=0;i<n;i++)
    {
         int min=oo;
         int index;
         for(int j=0;j<len;j++)
         {
              if(min>cost[j]+arr[j])
              {
                   min=cost[j]+arr[j];
                   index=j;
              }
         }
         cost[index]=min;
         rec[i]=min;
    }
}

bool cmp(const int &a,const int & b)
{
     return a>b;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值