实验3-栈和队列——表达式求值(2132)

数据结构实验之栈与队列二:一般算术表达式转换成后缀式

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Example Input
a*b+(c-d/e)*f#
Example Output
ab*cde/-f*+


代码:

#include<iostream>
#include<stack>
using namespace std;
stack<char> s;

int compare(char a,char b)
{
    if(b=='@')
        return 0;
    if( (a=='*'||a=='/')&&(b=='+'||b=='-') || (b=='(') )
        return 1;
    else
        return -1;
}

int main()
{
    char c;
    s.push('@');
    while(cin>>c&&c!='#')
    {
        if(c>='a'&&c<='z')
            cout<<c;
        else if(c=='(')
        {
            s.push('(');
        }
        else if(c==')')
        {
            while(s.top()!='(')
            {
                cout<<s.top();
                s.pop();
            }
            s.pop();
        }
        else
        {
            if(compare(c,s.top())==1)
                s.push(c);
            else if(compare(c,s.top())==-1)
            {
                cout<<s.top();
                s.pop();
                s.push(c);
            }
            else
            {
                s.pop();
                s.push(c);
            }
        }
    }
    while(!s.empty())
    {
        cout<<s.top();
        s.pop();
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值