D - Milking Time

                                                             Milking Time

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43

这是刚开始写的代码,超时,唉,我就知道不会这么简单~~

#include<iostream>
#include<algorithm>
using namespace std;

struct node
{
    int start,end,eff;
    int time;
}s[1001];

int cmp(node a,node b)
{
    return a.start<b.start;
}

int main()
{
    int n,m,r;
    cin>>n>>m>>r;
    for(int i=0;i<m;i++)
    {
        cin>>s[i].start>>s[i].end>>s[i].eff;
        s[i].time=s[i].end-s[i].start;
    }
    sort(s,s+m,cmp);
    int max=0;
    for(int i=0;i<n;i++)
    {
        int sum=s[i].eff;
        int end1=s[i].end;
        for(int j=i+1;j<n;j++)
        {
            if(end1+r<=s[j].start)
            {
                sum+=s[j].eff;
                end1=s[j].end;
            }
        }
        if(sum>max)
            max=sum;
    }
    cout<<max<<endl;
    return 0;
}


正确的的代码:

#include<iostream>
#include<algorithm>
using namespace std;

int dp[1001];  //dp[i]表示挤完第i个时间段的奶的最大挤奶量

struct node
{
    int start,end,eff;
    int time;
}s[1001];

int cmp(node a,node b)
{
    return a.start<b.start;
}

int main()
{
    int n,m,r;
    cin>>n>>m>>r;
    for(int i=0;i<m;i++)
    {
        cin>>s[i].start>>s[i].end>>s[i].eff;
        s[i].end+=r;
    }
    sort(s,s+m,cmp);
    for(int i=0;i<m;i++)
    {
        dp[i]=s[i].eff;
        for(int j=0;j<i;j++)
        {
            if(s[j].end<=s[i].start)
                dp[i]=max(dp[i],dp[j]+s[i].eff);
        }
    }
    sort(dp,dp+m);  //若第1、2个时间段都只能挤一次,则dp[1]=s[1].eff,dp[2]=s[2].eff
    cout<<dp[m-1]<<endl;  //此时要判断dp[1]dp[2]即s[1].eff,s[2].eff的大小
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值