B - Building Shops

B - Building Shops

HDU’s  nn classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these nn classrooms. 

The total cost consists of two parts. Building a candy shop at classroom  ii would have some cost  cici. For every classroom  PP without any candy shop, then the distance between  PP and the rightmost classroom with a candy shop on  PP's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side. 

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him. 
InputThe input contains several test cases, no more than 10 test cases. 
In each test case, the first line contains an integer  n(1n3000)n(1≤n≤3000), denoting the number of the classrooms. 
In the following  nn lines, each line contains two integers  xi,ci(109xi,ci109)xi,ci(−109≤xi,ci≤109), denoting the coordinate of the  ii-th classroom and the cost of building a candy shop in it. 
There are no two classrooms having same coordinate.OutputFor each test case, print a single line containing an integer, denoting the minimal cost.Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5
11

题意

给出n个地点的位置坐标xi和花费ci,对于每一个位置可以选择在花费ci建店或者花费左边离他最近的已建的位置的距离差,求最小花费

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;

LL dp[3005][2];  //dp[i][0]指i点没建的最小成本
                  //dp[i][1]指i点建了的最小成本
struct node
{
    LL id;
    LL mon;
}s[3010];

LL cmp(node a,node b)
{
    return a.id<b.id;
}

int main()
{
    int n;
    while(cin>>n)
    {
        memset(dp,inf,sizeof dp);
        memset(s,0,sizeof s);
        for(int i=0;i<n;i++)
            cin>>s[i].id>>s[i].mon;
        sort(s,s+n,cmp);
        dp[0][1]=s[0].mon;
        for(int i=1;i<n;i++)
        {
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+s[i].mon;
            LL ans=0;
            for(int j=i-1;j>=0;j--)  //不知道前面谁建了,设为j
            {
                ans+=(s[j+1].id-s[j].id)*(i-j);
                dp[i][0]=min(dp[i][0],dp[j][1]+ans);
            }
        }
        cout<<min(dp[n-1][0],dp[n-1][1])<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值