poj 2361 Tic Tac Toe

Tic Tac Toe
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2095 Accepted: 777

Description

Tic Tac Toe is a child's game played on a 3 by 3 grid. One player, X, starts by placing an X at an unoccupied grid position. Then the other player, O, places an O at an unoccupied grid position. Play alternates between X and O until the grid is filled or one player's symbols occupy an entire line (vertical, horizontal, or diagonal) in the grid. 
We will denote the initial empty Tic Tac Toe grid with nine dots. Whenever X or O plays we fill in an X or an O in the appropriate position. The example below illustrates each grid configuration from the beginning to the end of a game in which X wins. 
...  X..  X.O  X.O  X.O  X.O  X.O  X.O

...  ...  ...  ...  .O.  .O.  OO.  OO.

...  ...  ...  ..X  ..X  X.X  X.X  XXX

Your job is to read a grid and to determine whether or not it could possibly be part of a valid Tic Tac Toe game. That is, is there a series of plays that can yield this grid somewhere between the start and end of the game?

Input

The first line of input contains N, the number of test cases. 4N-1 lines follow, specifying N grid configurations separated by empty lines.

Output

For each case print "yes" or "no" on a line by itself, indicating whether or not the configuration could be part of a Tic Tac Toe game.

Sample Input

2
X.O
OO.
XXX

O.X
XX.
OOO

Sample Output

yes
no

Source


思路:

无效棋盘,至少会呈现下述5种特征之一:

1.O的点多于X的点

2.O和X同时赢

3.X的点比O的点多出2个或以上

4.X赢,但X的个数与O的个数一样多

5.O赢,但X比O的个数多一个


源代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
#define maxn 5
#define inf 0x7ffffff
char arr[maxn][maxn];
int n;
bool x,o;
void check();
int main()
{
    scanf("%d",&n);

    while(n--){
        getchar();
        for(int i = 0; i < 3; i++){
            gets(arr[i]);
        }
        int cnto = 0;
        int cntx = 0;
        for(int i = 0; i < 3; i++){
            for(int j = 0; j < 3; j++){
                if(arr[i][j] == 'X'){
                    cntx++;
                }else if(arr[i][j] == 'O'){
                    cnto++;
                }
            }
        }
        if(cnto > cntx || cntx - cnto > 1){
            printf("no\n");
           continue ;
        }
        x = false, o = false;
        check();
        if(cnto == cntx && x){
            printf("no\n");
            continue;
        }
        if((x && o) || (o && cntx != cnto)){
            printf("no\n");
            continue;
        }
        printf("yes\n");
    }
    return 0;
}
void check(){
    char tmp = arr[0][0];
    if(tmp != '.'){
        if(arr[0][1] == tmp && arr[0][2] == tmp){
            if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }else if(tmp == arr[1][0] && tmp == arr[2][0]){
            if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }else if(tmp == arr[1][1] && tmp == arr[2][2]){
             if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }
    }
    tmp = arr[0][1];
    if(tmp != '.'){
        if(arr[1][1] == tmp && tmp == arr[2][1]){
             if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }
    }
    tmp = arr[0][2];
    if(tmp != '.'){
        if(arr[1][2] == tmp && tmp == arr[2][2]){
             if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }else if(arr[1][1] == tmp &&tmp == arr[2][0]){
             if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }
    }
    tmp = arr[1][0];
    if(tmp != '.'){
        if(arr[1][1] == tmp && tmp == arr[1][2]){
             if(tmp == 'X'){
                x = true;
            }else{
                o = true;
            }
        }
    }
    tmp = arr[2][0];
    if(tmp != '.'){
        if(tmp == arr[2][1] && tmp == arr[2][2]){
             if(tmp == 'X'){
                    x = true;
                }else{
                    o = true;
                }
        }
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值