数据结构实验之链表四:有序链表的归并

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
输入
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
输出
输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100

提示

不得使用数组!

来源

初学者也不会更高级的算法,按照他说的先建立好两个链表,然后再开一个同时遍历两个链表,把小的放在先开的链表后面。
AC代码:

//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <string>
#include <stack>
#include <set>
#include <queue>
#include <algorithm>
#define CLR(a, b) memset(a, (b), sizeof(a))
#define INF 0x3f3f3f3f
#define eps 1e-8
typedef long long LL;
using namespace std;

typedef struct Node
{
    int date;
    struct Node *next;
} node;
node* creat(int n)
{
    node *head=(node *)malloc(sizeof(node));
    head->next=NULL;
    node *pr=head;
    int date;
    for(int i=0; i<n; i++)
    {
        scanf("%d",&date);
        if(i==0)
        {
            pr->date=date;
        }
        else
        {
            node *p=(node *)malloc(sizeof(node));
            p->date=date;
            p->next=NULL;
            pr->next=p;
            pr=pr->next;
        }
    }
    return head;
}
node *combine(node *head1,node *head2)
{
    node *pr1=head1,*pr2=head2;
    node *head=(node *)malloc(sizeof(node));
    node *pr=head;
    pr->next=NULL;
    int cnt=0;
    while(pr1!=NULL&&pr2!=NULL)
    {
        if(cnt==0)
        {
            cnt=1;
            if(pr1->date<pr2->date)
            {
                pr->date=pr1->date;
                pr1=pr1->next;
            }
            else
            {
                pr->date=pr2->date;
                pr2=pr2->next;
            }


        }
        else
        {
            node *p=(node *)malloc(sizeof(node));
            if(pr1->date<pr2->date)
            {
                p->date=pr1->date;
                p->next=NULL;
                pr->next=p;
                pr=pr->next;
                pr1=pr1->next;
            }
            else
            {
                p->date=pr2->date;
                p->next=NULL;
                pr->next=p;
                pr=pr->next;
                pr2=pr2->next;
            }
        }
    }
    if(pr1==NULL&&pr2!=NULL)
        pr->next=pr2;
    else if(pr1!=NULL&&pr2==NULL)
        pr->next=pr1;


    return head;


}
void show(node *head)
{
    node *pr=head;
    while(pr->next!=NULL)
    {
        printf("%d ",pr->date);
        pr=pr->next;
    }
    printf("%d\n",pr->date);
}
int main()
{
#ifdef LOCAL
    freopen("E://in.txt","r",stdin);
#endif // LOCAL
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        node *head1=creat(m);
        node *head2=creat(n);

//        show(head1);
//        show(head2);
        head1=combine(head1,head2);
        show(head1);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值