hdu6213 Chinese Zodiac

hdu6213 Chinese Zodiac

Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integer T (1T1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  
  
3 ox rooster rooster ox dragon dragon

Sample Output
  
  
8 4 12
题目大意:

一个年长的女人要和一个帅气的年轻人结婚, 两个人的年龄差不超过12岁。我们只能够根据两人出生年份的生肖,来得到两人的年龄差。


我的做法:

先用一个字符串数组存储十二生肖,然后根据两人出生年份的生肖得到一个年龄差。

样例一:直接rooster - ox,得8

样例二:ox + 12 - rooster,得4(女人的年龄大,即rooster表示的年份小一些)

样例三:dragon - dragon == 0, 直接输出12


通过一个mod12把三种情况统一起来,即:(男人生肖 + 12 - 女人生肖) % 12,若结果为0输出12。


AC代码:

#include <stdio.h>
#include <iostream>
#include <string>
using namespace std;

int main()
{
    string zodiac[15] = {"rat", "ox", "tiger", "rabbit", "dragon", "snake", "horse", "sheep", "monkey", "rooster", "dog", "pig"};
    int t;

    cin >> t;
    while(t--)
    {
        string a, b;
        int aint = 0, bint = 0;

        cin >> a >> b;
        for(int i = 0; i < 12; i++)
        {
            if(a == zodiac[i])
                aint = i + 1;  //数组0开始
            if(b == zodiac[i])
                bint = i + 1;
        }
        int ans = (bint + 12 - aint) % 12;  //把样例ox rooster 和 rooster ox的情况一起处理了

        printf("%d\n", ans ? ans : 12);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值