POJ 1163: The Triangle(dp)

【原题】
Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
【Input】
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
【Output】
Your program is to write to standard output. The highest sum is written as an integer.
【Sample Input】
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
【Sample Output】
30
【题意】
给出一个数字三角形,从三角形顶部数字走,每次只能走到这个数字的左下角或者右下角的数字,直到底部,计算走过的线路的数字之和,求这个和的最大值
这是经典dp 问题,因为我最近才接触动态规划,惊奇地发现题都特别有意思,只要能找到递推方程,问题就很容易解决了。
从底层向上递推,方程为:
dp[i][j]=max(num[i][j]+dp[i+1][j],num[i][j]+dp[i+1][j+1])

#include<cstdio>
#include<iostream>

using namespace std;
const int maxn = 100 + 5;
int dp[maxn][maxn];
int num[maxn][maxn];

int main() {
    int n;
    int i, j;
    scanf("%d", &n);
    for (i = 1; i <= n; i++)
        for (j = 1; j <= i; j++)
            scanf("%d", &num[i][j]);
    for (i = 1; i <= n; i++)                //初始化
        dp[n][i] = num[n][i];
    for (i = n - 1; i > 0; i--)             //从底层向上递推
        for (j = 1; j <= i; j++)
            dp[i][j] = max(num[i][j] + dp[i + 1][j], num[i][j] + dp[i + 1][j + 1]);
    printf("%d\n", dp[1][1]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值