杭电ACM2052java做法

Picture

Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line. 

Sample Input
3 2

Sample Output
+---+
|   |
|   |

+---+


感觉这道题比较水吧,我没想啥好办法,就直接打了


import java.util.Scanner;

public class Main {
    public static void main(String[] args){
        Scanner scanner=new Scanner(System.in);
        while(scanner.hasNextInt()){
            int a=scanner.nextInt();
            int b=scanner.nextInt();
            for(int i=0;i<b+2;i++){
                if(i==0||i==b+1){
                    System.out.print("+");
                    for(int j=1;j<a+1;j++){
                        System.out.print("-");
                    }
                    System.out.println("+");
                }
                else{
                    System.out.print("|");
                    for(int j=1;j<a+1;j++){
                        System.out.print(" ");
                    }
                    System.out.println("|");
                }
            }
            System.out.println();
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值