POJ2631

3 篇文章 0 订阅
2 篇文章 0 订阅

斯丢匹德的我又一次制杖了。。。
Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output

You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

裸题树的直径。。。然后!加权值的时候我把加权的过程写在函数外面了。。。然后主要是还写错了。。。
先上正解吧。。。

#include<cstdio>
#include<iostream>
#include<cstring>
#define MAXN 10005
using namespace std;
int w;
int q[MAXN];
bool vis[MAXN];
int dis[MAXN];
struct Edge {
    int to,next,len;
} edge[MAXN];
int a,b;
int mx=0;
int cnt;
int head[MAXN];
void add(int x,int y,int z) {
    edge[++cnt].to=y;
    edge[cnt].next=head[x];
    edge[cnt].len=z;
    head[x]=cnt;
}
int rem;
void bfs(int a) {
    int hd=1,tl=1;
    q[1]=a;
//  dis[1]=0;
    while(hd<=tl) {
        int u=q[hd];
        for(int i=head[u]; i>0; i=edge[i].next) {
            int v=edge[i].to;
            if(!vis[v]) {
                vis[v]=1;
                tl++;
                q[tl]=v;
                dis[tl]=dis[hd]+edge[i].len;
                if(mx<dis[tl]) {
                    mx=dis[tl];
                    rem=v;
                }
            }
        }
        hd++;
    }
}
void mem(int r[]) {
    memset(r,0,sizeof r);
}
int main() {
    int i=1;
    while(~scanf("%d%d%d",&a,&b,&w)) {
        add(a,b,w);
        add(b,a,w);
//      edge[i].len =w;
//      i++;
    }

    vis[1]=1;
    bfs(1);
//  cout<<rem;
//  mem(vis);
    memset(vis,0,sizeof vis);
    mem(dis);
    mx=0;
    vis[rem]=1;
    bfs(rem);
    cout<<mx;

}

然后错的代码。。。不想说啥。。写注释的地方就是我制杖的地方

#include<cstdio>
#include<iostream>
#include<cstring>
#define MAXN 10005
using namespace std;
int w[MAXN];
int q[MAXN];
bool vis[MAXN];
int dis[MAXN];
struct Edge {
    int to,next,len;
} edge[MAXN];
int a,b;
int mx=0;
int cnt;
int head[MAXN];
void add(int x,int y) {
    edge[++cnt].to=y;
    edge[cnt].next=head[x];
    head[x]=cnt;
}
int rem;
void bfs(int a) {
    int hd=1,tl=1;
    q[1]=a;
//  dis[1]=0;
    while(hd<=tl) {
        int u=q[hd];
        for(int i=head[u]; i>0; i=edge[i].next) {
            int v=edge[i].to;
            if(!vis[v]) {
                vis[v]=1;
                tl++;
                q[tl]=v;
                dis[tl]=dis[hd]+edge[i].len;
                if(mx<dis[tl]) {
                    mx=dis[tl];
                    rem=v;
                }
            }
        }
        hd++;
    }
}
void mem(int r[]) {
    memset(r,0,sizeof r);
}
int main() {
    int i=1;
    while(~scanf("%d%d%d",&a,&b,&w)) {
        add(a,b);
        add(b,a);
        edge[i].len =w[i];//蒟蒻的日常 
        i++;
    }

    vis[1]=1;
    bfs(1);
    cout<<rem;
//  mem(vis);
    memset(vis,0,sizeof vis);
    mem(dis);
    mx=0;
    vis[rem]=1;
    bfs(rem);
    cout<<mx;

}

看到一个dalao写的链式前向星的讲解。。然后就想转过来。。然而不太会用这玩意。。。

http://blog.csdn.net/acdreamers/article/details/16902023
转自“ACdreamer”。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值