poj 1894 Alternative Scale of Notation

Alternative Scale of Notation
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions:2182 Accepted: 808

Description

One may define a map of strings over an alphabet Σ B = { C1, C2, . . . C B } of size B to non-negative integer numbers, using characters as digits C1 = 0, C2 = 1, . . . , C B = B - 1 and interpreting the string as the representation of some number in a scale of notation with base B. Let us denote this map by U B , for a string α[ 1...n ] of length n we put 
UB(α)=Σ0<=i<=n-1α[n-i]*Bi

For example, U3(1001) = 1*27 + 0*9 + 0*3 + 1*1 = 28. 

However, this correspondence has one major drawback: it is not ont-to-one. For example, 
28 = U3(1001) = U3(01001) = U3(001001) = ... , 
infinitely many strings map to the number 28. 

In mathematical logic and computer science this may be unacceptable. To overcome this problem, the alternative interpretation is used. Let us interpret characters as digits, but in a slightly different way: C1 = 1, C2 = 2, . . . , C B = B . Note that now we do not have 0 digit, but rather we have a rudiment B digit. Now we define the map V B in a similar way, for each string α[ 1...n ] of length n we put 
VB(α)=Σ0<=i<=n-1α[n-i]*Bi

For an empty string ε we put V B(ε) = 0. 

This map looks very much like U B , however, the set of digits is now different. So, for example, we have V3(1313) = 1*27 + 3*9 + 1*3 + 3*1 = 60. 

It can be easily proved that the correspondence defined by this map is one-to-one and onto. Such a map is called bijective, and it is well known that every bijective map has an inverse. Your task in this problem is to compute the inverse for the map V B . That is, for a given integer number x you have to find the string α, such that V B(α) = x. 

Input

The first line contains B (2 <= B <= 9) and the second line contains an integer number x given in a usual decimal scale of notation, 0 <= x <= 10 100.

Output

Output in one line such string α, consisting only of digits from the set { 1, 2, . . . , B }, that V B(α) = x . 

Sample Input

3
60

Sample Output

1313

Source


import java.io.*;
import java.math.BigInteger;
import java.nio.Buffer;
import java.util.*;
public class Main
{
    public static void main(String args[]) throws Exception
    {
        Scanner cin=new Scanner(System.in);
        BigInteger n=cin.nextBigInteger();
        BigInteger a=cin.nextBigInteger();
        BigInteger x=BigInteger.valueOf(0);
        String s="";
        while (a.compareTo(BigInteger.valueOf(0))>0){
            if(a.remainder(n).equals(BigInteger.valueOf(0))){
                s+=n.toString();
                a=a.subtract(n);
                a=a.divide(n);
            }
            else{
                s+=a.remainder(n).toString();
                a=a.divide(n);
            }

        }

        s = new StringBuffer(s).reverse().toString();
        System.out.print(s);

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值