hdu 3506 Monkey Party 四边形不等式优化区间dp

Monkey Party

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1926    Accepted Submission(s): 838


Problem Description
Far away from our world, there is a banana forest. And many lovely monkeys live there. One day, SDH(Song Da Hou), who is the king of banana forest, decides to hold a big party to celebrate Crazy Bananas Day. But the little monkeys don't know each other, so as the king, SDH must do something. 
Now there are n monkeys sitting in a circle, and each monkey has a making friends time. Also, each monkey has two neighbor. SDH wants to introduce them to each other, and the rules are: 
1.every time, he can only introduce one monkey and one of this monkey's neighbor. 
2.if he introduce A and B, then every monkey A already knows will know every monkey B already knows, and the total time for this introducing is the sum of the making friends time of all the monkeys A and B already knows; 
3.each little monkey knows himself; 
In order to begin the party and eat bananas as soon as possible, SDH want to know the mininal time he needs on introducing. 
 

Input
There is several test cases. In each case, the first line is n(1 ≤ n ≤ 1000), which is the number of monkeys. The next line contains n positive integers(less than 1000), means the making friends time(in order, the first one and the last one are neighbors). The input is end of file.
 

Output
For each case, you should print a line giving the mininal time SDH needs on introducing.
 

Sample Input
 
 
8 5 2 4 7 6 1 3 9
 

Sample Output
 
 
105
 

不优化会超时。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;

const int max_n=2000+5;
const int INF=1<<30;
int n;
int a[max_n];
int dp[max_n][max_n];
int sum[max_n];
int s[max_n][max_n];

void print(){
    for(int i=1;i<=2*n-1;i++){
        printf("%5d",(i-1)%n+1);
    }
    cout<<endl;
    for(int i=1;i<=n;i++){
        for(int k=1;k<i;k++){
            printf("%5d",0);
        }
        for(int j=i;j<=2*n-1;j++){
            printf("%5d",dp[i][j]);
        }
        cout<<endl;
    }

}

void solve(){
    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            a[n+i]=a[i];
        }

        sum[0]=0;
        for(int i=1;i<=2*n-1;i++){
            dp[i][i]=0;
            s[i][i]=i;
            sum[i]=sum[i-1]+a[i];
        }


        for(int i=2*n-1;i>=1;i--){
            for(int j=i+1;j<=2*n-1&&j<=i+n-1;j++){
                int temp=INF;
                int w;
                for(int k=s[i][j-1];k<=s[i+1][j];k++){
                    if(temp>dp[i][k]+dp[k+1][j]+sum[j]-sum[i-1]){
                        temp=dp[i][k]+dp[k+1][j]+sum[j]-sum[i-1];
                        w=k;
                    }
                }
                dp[i][j]=temp;
                s[i][j]=w;
            }
        }

        int ans=INF;
        for(int i=n;i<=2*n-1;i++){
            ans=min(ans,dp[i-n+1][i]);
        }
        printf("%d\n",ans);
        //print();
    }


}

int main()
{
    solve();

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值