sgu 123. The sum 递推

123. The sum

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

The Fibonacci sequence of numbers is known: F1 = 1; F2 = 1; Fn+1 = Fn + Fn-1, for n>1. You have to find S - the sum of the first K Fibonacci numbers.

Input

First line contains natural number K (0<K<41).

Output

First line should contain number S.

Sample Input

5

Sample Output

12


计算斐波那契数列前N项和,水了。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;


long long x[45];

void solve(){
    x[1]=x[2]=1;
    for(int i=3;i<=41;i++){
        x[i]=x[i-1]+x[i-2];
    }
    int n;
    scanf("%d",&n);
    long long ans=0;
    for(int i=1;i<=n;i++){
        ans+=x[i];
    }
    printf("%lld",ans);

}




int main() {


#ifdef LOCAL_DEFINE
    freopen("input.txt", "rt", stdin);
#endif

    solve();


    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值