sgu 107. 987654321 problem 找规律

107. 987654321 problem

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

For given number N you must output amount of N-digit numbers, such, that last digits of their square is equal to 987654321.

Input

Input contains integer number N (1<=N<=106)

Output

Write answer to the output.

Sample Input

8

Sample Output

0


暴力找规律然后补零

#include <bits/stdc++.h>

using namespace std;

void find_them(){
   long long a=999999999;
    for(long long  i=1;i<=a;i++){
        if(i*i%1000000000==987654321){
            cout<<i<<endl;
        }
    }
}

void solve(){
    //find_them();
    int n;
    scanf("%d",&n);
    if(n<=8){
        printf("0");
    }
    else if(n==9){
        printf("8");
    }
    else{
        printf("72");
        for(int i=0;i+10<n;i++){
            printf("0");
        }
    }

}

int main(){
    solve();
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值