105. Div 3
time limit per test: 0.25 sec.
memory limit per test: 4096 KB
There is sequence 1, 12, 123, 1234, ..., 12345678910, ... . Given first N elements of that sequence. You must determine amount of numbers in it that are divisible by 3.
Input
Input contains N (1<=N<=231 - 1).
Output
Write answer to the output.
Sample Input
4
Sample Output
2
#include <bits/stdc++.h>
using namespace std;
void solve(){
int n;
scanf("%d",&n);
printf("%d",n/3*2+(n%3==2));
}
int main(){
solve();
return 0;
}