LightOJ 1045 I - Digits of Factorial

Description
Factorial of an integer is defined by the following function

f(0) = 1
f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input
Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output
For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input
5
5 10
8 10
22 3
1000000 2
0 100
Sample Output
Case 1: 3
Case 2: 5
Case 3: 45
Case 4: 18488885
Case 5: 1

题意:n!的m进制一共多少位————————————-
想到了怎么预处理,可惜没想到对数这个工具orz
log(n!) = log(n)+log(n-1) + log(n-2) +…+log(2)
例子:4!=24,24是十进制的2位,因为>10,5!=120,是十进制的3位,因为>100,所以直接对数化
反思:当题目要求求位数的时候应该要想到对数这个工具。

log(i)为自然对数

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstdlib>
using namespace std;
const int N=1000005;
double num[N];
int main (void)
{
    int t,cas=0;
    for(int i=1;i<=N-1;i++)
    {
        num[i]=num[i-1]+log(i);
    }
    cin>>t;
    while(t--)
    {
        int n,base;
        cas++;
        scanf("%d %d",&n,&base);
        int ans;
        ans=floor(num[n]/log(base)+1);//floor向下取整
        //事实证明不用floor也行
        printf("Case %d: %d\n",cas,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值