[HOJ 10146] Number lengths

Number lengths
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 1509, Accepted users: 1405
Problem 10146 : No special judgement
Problem description
N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * ... * 2 * 1)
 
Input
Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.
 
Output
For each value of N, print out how many digits are in N!.
 
Sample Input
1
3
32000
1000000
Sample Output
1 
1
130271
5565709
Problem Source
UD Contest

AC:

解法1:使用 stirling 公式

 

 

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>   
#include <cmath>

#define pi 3.1415926535897
// stirling 公式 : lg (n !) = 1 / 2 lg (2 * pi) + (n + 1/2) * lg(n)  - n lg(e)
// 换底公式:logn(m) = lga(m) / lga(n)

int calc(int n)
{
    if (n <= 3) return 1;
    return floor((0.5 * log(2*pi) + (n + 0.5) * log(n) - n) / double(log(10)) + 1); // 必须用 double,不要使用 1/2,否则精度损失
}

int main()
{
    int n;
    while (~scanf("%d", &n))
    {
        printf("%d\n", calc(n));
    }
    return 0;
}

解法2:直接利用 log(a*b) = log(a) + log(b) 展开求和

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>   
#include <cmath>

int calc(int n)
{
    if (n == 0) return 1;
    double s = 1;
    for (int i = 1; i <= n; ++i) s += double(log10(double(i)));
    return floor(s);
}

int main()
{
    int n;
    while (~scanf("%d", &n))
        printf("%d\n", calc(n));
    return 0;
}

方案一更快,也更省内存。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值