Number lengths FZU - 1050

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * … * 2 * 1)

Input
Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.

Output
For each value of N, print out how many digits are in N!.

Sample Input
1
3
32000
Sample Output
1
1
130271

//N!位数应该是 log10(1)+log10(2)+···+log10(n) 取整加1,
//注意:log10(n)传入的值必须是double型,所以要进行强制转换!
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

const int INF=1e9+7;
const int maxn=110;
typedef long long ll;

int n;

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j=0;
        double sum=0;
        for(i=1; i<=n; i++)
            sum+=log10(double(i));
        j=(int)sum+1;
        printf("%d\n",j);
    }
    return 0;
}

转载于:https://www.cnblogs.com/nyist-xsk/p/7264847.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sure, I can help you with that. A non-weighted histogram of read lengths is a graphical representation of the distribution of read lengths in a set of sequencing data. In this type of histogram, each read length is represented by a single count, regardless of the number of times that length occurs in the dataset. To create a non-weighted histogram of read lengths, you can follow these steps: 1. Collect the read length data from your sequencing dataset. 2. Determine the range of read lengths in your dataset. 3. Divide the range of read lengths into a series of bins, each representing a range of read lengths. 4. Count the number of reads in each bin. 5. Plot the bin counts on the y-axis and the bin ranges on the x-axis to create a histogram. Here's an example code snippet in Python to create a non-weighted histogram of read lengths using the Matplotlib library: ``` import matplotlib.pyplot as plt # Example read length data read_lengths = [100, 200, 300, 400, 500, 200, 300, 300, 100, 100, 200, 500, 500] # Define the bin ranges bins = range(0, 600, 100) # Count the number of reads in each bin bin_counts, _, _ = plt.hist(read_lengths, bins=bins, color='blue') # Plot the histogram plt.xlabel('Read length') plt.ylabel('Count') plt.title('Non-weighted histogram of read lengths') plt.show() ``` This code will create a histogram with five bins representing read lengths from 0-100, 100-200, 200-300, 300-400, and 400-500. The bin counts will be [4, 4, 3, 1, 2], respectively, and the resulting histogram will show the distribution of read lengths in the dataset.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值