USACO-Subset Sums

For many sets of consecutive integers from 1 through N (1 <= N <= 39), one can partition the set into two sets whose sums are identical.

For example, if N=3, one can partition the set {1, 2, 3} in one way so that the sums of both subsets are identical:

{3} and {1,2}
This counts as a single partitioning (i.e., reversing the order counts as the same partitioning and thus does not increase the count of partitions).

If N=7, there are four ways to partition the set {1, 2, 3, … 7} so that each partition has the same sum:

{1,6,7} and {2,3,4,5}
{2,5,7} and {1,3,4,6}
{3,4,7} and {1,2,5,6}
{1,2,4,7} and {3,5,6}
Given N, your program should print the number of ways a set containing the integers from 1 through N can be partitioned into two sets whose sums are identical. Print 0 if there are no such ways.

Your program must calculate the answer, not look it up from a table.

PROGRAM NAME: subset
INPUT FORMAT
The input file contains a single line with a single integer representing N, as above.

SAMPLE INPUT (file subset.in)
7
OUTPUT FORMAT
The output file contains a single line with a single integer that tells how many same-sum partitions can be made from the set {1, 2, …, N}. The output file should contain 0 if there are no ways to make a same-sum partition.

SAMPLE OUTPUT (file subset.out)
4

题意:给你从1-n的连续数字,求有多少种将它们平分成两部分的方法。

等差数列求和公式:S=(n+1)*n/2。
要平分,每一部分为S1=(n+1)*n/4,于是在开头判断S1是否为整数,不能则直接不能。
接着dp,最后要除以2,因为会算重复一次。

f[i,j]=f[i-1,j]+f[i-1,j-i] ,j-i>=0
f[i,j]=f[i-1,j] ,j-i<0

代码:

/*
ID:iam666
PROG:subset
LANG:C++
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
using namespace std;
long long dp[800];
int n;
int main (void)
{
    //freopen("subset.in","r",stdin);
    //freopen("subset.out","w",stdout);
    cin>>n;
    if(n*(n+1)%4)
        {
            printf("0\n");
            return 0;
        }
    int re=n*(n+1)/4;
    memset(dp,0,sizeof(dp));
    for(int i=0;i<=n;i++)
    dp[0]=1;
    for(int i=1;i<=n;i++)
    {
        for(int j=re;j>=i;j--)
        {
            dp[j]=dp[j]+dp[j-i];//j比i多出来的数的分法加上原来的分法
        //  printf("%lld___\n",dp[j]);
        }
    //  printf("*******\n");
    }
    printf("%lld\n",dp[re]/2);
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值