usaco subset sums

Subset Sums
JRM

For many sets of consecutive integers from 1 through N (1 <= N <= 39), one can partition the set into two sets whose sums are identical.

For example, if N=3, one can partition the set {1, 2, 3} in one way so that the sums of both subsets are identical:

  • {3} and {1,2}

This counts as a single partitioning (i.e., reversing the order counts as the same partitioning and thus does not increase the count of partitions).

If N=7, there are four ways to partition the set {1, 2, 3, ... 7} so that each partition has the same sum:

  • {1,6,7} and {2,3,4,5}
  • {2,5,7} and {1,3,4,6}
  • {3,4,7} and {1,2,5,6}
  • {1,2,4,7} and {3,5,6}

Given N, your program should print the number of ways a set containing the integers from 1 through N can be partitioned into two sets whose sums are identical. Print 0 if there are no such ways.

Your program must calculate the answer, not look it up from a table.

PROGRAM NAME: subset

INPUT FORMAT

The input file contains a single line with a single integer representing N, as above.

SAMPLE INPUT (file subset.in)

7

OUTPUT FORMAT

The output file contains a single line with a single integer that tells how many same-sum partitions can be made from the set {1, 2, ..., N}. The output file should contain 0 if there are no ways to make a same-sum partition.

SAMPLE OUTPUT (file subset.out)

4
/*
  ID:
  PROG: subset
  LANG: C++
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 40
using namespace std;
typedef  long long llong;
llong dp[MAX][1000];//dp[i][j]表示前i个数总量为j有几种情况
int N;
int main()
{
    freopen("subset.in","r",stdin);
    freopen("subset.out","w",stdout);
    scanf("%d",&N);
    //如果总数是奇数,那么无法分成两份,所以打印0
    if((1+N)*N/2%2){
        printf("0\n");
        return 0;
    }
    memset(dp,0,sizeof(dp));
    dp[1][1] = 1;
    dp[1][0] = 1;
    for(int i = 2; i <= N;i++){
        for(int j = 0; j <= N*(N+1)/4 ;j++){
            //j比i大说明i可能要了也可能没要
            if(j >= i) dp[i][j] = dp[i - 1][j] + dp[i - 1][j - i];//dp[i-1][j]说明i没有要,dp[i-1][j-i]说明i要了所以j要减i
        else dp[i][j] = dp[i - 1][j];//j比i小说明第i个并没有要所以返回dp[i-1][j]
        }
    }
    printf("%lld\n",dp[N][N*(N+1)/4]/2);//前N种总量为N*(N+1)/4,这需要除2得到结果
}
感觉自己还是不太懂背包问题诶,这道题是每一个数判断它拿了还是没拿,总值要为一个定值。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值