USACO-The Tamworth Two

A pair of cows is loose somewhere in the forest. Farmer John is lending his expertise to their capture. Your task is to model their behavior.

The chase takes place on a 10 by 10 planar grid. Squares can be empty or they can contain:

an obstacle,
the cows (who always travel together), or
Farmer John.
The cows and Farmer John can occupy the same square (when they `meet’) but neither the cows nor Farmer John can share a square with an obstacle.
Each square is
represented
as follows:

. Empty square
* Obstacle
C Cows
F Farmer
Here is a sample grid:
…..
……*…
..
……….
…*.F….
…..
…*……
..C……*
.….
..……
The cows wander around the grid in a fixed way. Each minute, they either move forward or rotate. Normally, they move one square in the direction they are facing. If there is an obstacle in the way or they would leave the board by walking `forward’, then they spend the entire minute rotating 90 degrees clockwise.

Farmer John, wise in the ways of cows, moves in exactly the same way.

The farmer and the cows can be considered to move simultaneously during each minute. If the farmer and the cows pass each other while moving, they are not considered to have met. The chase ends when Farmer John and the cows occupy the same square at the end of a minute.

Read a ten-line grid that represents the initial state of the cows, Farmer John, and obstacles. Each of the ten lines contains exactly ten characters using the coding above. There is guaranteed to be only one farmer and one pair of cows. The cows and Farmer John will not initially be on the same square.

Calculate the number of minutes until the cows and Farmer John meet. Assume both the cows and farmer begin the simulation facing in the `north’ direction. Print 0 if they will never meet.

PROGRAM NAME: ttwo

INPUT FORMAT

Lines 1-10: Ten lines of ten characters each, as explained above
SAMPLE INPUT (file ttwo.in)

…..
……*…
..
……….
…*.F….
…..
…*……
..C……*
.….
..……
OUTPUT FORMAT

A single line with the integer number of minutes until Farmer John and the cows meet. Print 0 if they will never meet.
SAMPLE OUTPUT (file ttwo.out)

49

题意:牛和人只能往前走,遇到障碍和边缘时就顺时针旋转90度,旋转和往前走都要花费1时间,问经过多长时间牛和人会相遇。

模拟题,每一次可能有上下左右和不走5种情况,最多只有500*500步,如果超过了还没有相遇就不可能相遇了,因为之后的一定会是重复的路线。

代码:

/*
ID:iam666
PROG:ttwo
LANG:C++
*/
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
int main (void)
{
    freopen("ttwo.in","r",stdin);
    freopen("ttwo.out","w",stdout);
    int fx,fy,cx,cy;
    int ob[11][11],dc=0,df=0;
    int go[4][2]={{-1,0},{0,1},{1,0},{0,-1}};
    memset(ob,0,sizeof(ob));
    for(int i=1;i<=10;i++)
    {
        for(int j=1;j<=10;j++)
        {
            char c;
            cin>>c;
            if(c=='*')
                ob[i][j]=1;
            if(c=='F')
            {
                fx=i,fy=j;
            }
            if(c=='C')
            {
                cx=i,cy=j;
            }
        }
    }
    int time=0,x,y;
    while(1)
    {
        if(fx==cx&&fy==cy)
            break;
        x=fx+go[df][0];
        y=fy+go[df][1];
        if((ob[x][y]==1)||(x<1)||x>10||y<1||y>10)
            df=(df+1)%4;
        else
        {
            fx=x;
            fy=y;
        }
        x=cx+go[dc][0];
        y=cy+go[dc][1];
        if((ob[x][y]==1)||(x<1)||x>10||y<1||y>10)
            dc=(dc+1)%4;
        else
        {
            cx=x;
            cy=y;
        }
        time++;
        if(time>250000)
            break;
    }
    if(time<=250000)
        printf("%d\n",time);
    else
        printf("0\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值