Aaronson

Problem Description
Recently, Peter saw the equation x0+2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi is minimum and every xi (0≤i≤m) is non-negative.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers n and m (0≤n,m≤109).

Output
For each test case, output the minimum value of ∑i=0mxi.

Sample Input
10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output
1
2
2
3
2
2
3
2
3
2

Source
BestCoder Round #84

Recommend
wange2014 | We have carefully selected several similar problems for you: 5751 5750 5749 5747 5746

若位数要求比这个数的二进制位数大,直接算位数。

否则,先将多出来的位数压进最高位。

之后的每一位,1按1算,0按0算。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
int ch[100];
using namespace std;
int work(int n)
{
    int le=0;
    while(n!=0)
    {
        ch[le++]=n%2;
        n/=2;
    }
    return le;
}
int main (void)
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        scanf("%d %d",&n,&m);
        int re=work(n);
        long long ans=0;
        if(re<=m)
        {
            for(int i=re-1;i>=0;i--)
            {
                    if(ch[i]==1)
                       ans++;
            }
                    printf("%I64d\n",ans);
                    continue;
        }
        if(re>m)
        {
            ans+=n>>m;//将多出来的位数压进去
            n%=(1<<m);//将n变小
            while(n)
            {
                if(n&1)//如果是1,加1
                {
                    ans++;
                }
                n>>=1;
            }
             printf("%I64d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值