PTA C语言 7-2 jmu-ds-最长数字序列

输入一个字符串,求该字符串中最长连续数字序列出现的起始位置及其长度。

输入格式:

输入一个字符串,可包含空格。

输出格式:

输出内容:最长数字序列起始位置和长度空格隔开。输出尾部不能有空格。输入空串,输出"NULL"

输入样例:

123ab12345a

输出样例:

5 5

答案:

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <string.h>
#include <ctype.h>
int is_continuous(char* ps,int i)
{
	int temp = 0;
	if ((char)*(ps + i) >= '0' && (char)*(ps + i) <= '9')
	{
		while ((char)*(ps + i) >= '0' && (char)*(ps + i) <= '9')
		{
			temp++;
			i++;
		}
		return temp;
	}
	else if (((char)*(ps + i) >= 'A' && (char)*(ps + i) <= 'Z')|| ((char)*(ps + i) >= 'a' && (char)*(ps + i) <= 'z'))
	{
		while (((char)*(ps + i) >= 'A' && (char)*(ps + i) <= 'Z') || ((char)*(ps + i) >= 'a' && (char)*(ps + i) <= 'z'))
		{
			temp++;
			i++;
		}
		return -temp;
	}
}
int main()
{
	char arr[100] = {'\0'};
	fgets(arr, sizeof(arr), stdin);
	int flag = 1;
	int j = 0;
	while (arr[j] != '\n')
	{
		if (!isspace(arr[j]))
		{
			flag = 0;
		}
		j++;
	}
	if (flag == 1)
	{
		printf("NULL");
		return 0;
	}
	int  i = 0, max = 0, size = 0;
	while (arr[i]!='\0')
	{
		int temp = 0;
		temp = is_continuous(&arr[0],i);
		if (temp > 0)
		{
			if (temp > max)
			{
				max = temp;
				size += i;
			}
			i += temp;
		}
		else
		{
			i += -temp;
		}
		
	}
	if (i == 0)
	{
		printf("NULL");
	}
	else
	{
		printf("%d %d", size, max);
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值