杭电2602“Bone Collector”.(DP)

杭电acm一些细节上的思考:
养成这样移个习惯,在定义数组的时候,最好把数组定义在main函数之外。
在实际编程中必须考虑数组的大小。
在函数中能定义多大的数组取决于编译是指定栈空间的大小,对于过大的数组,定义在函数里会照成栈的溢出错误,如果定义在函数外,则是在静态内存去定义,该区域32位系统会给每个进程分配3G的虚拟内存。

杭电2602
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output
14

01背包问题

#include<iostream>
#include <stdio.h>
using namespace std;
int m[1005][1005], v[1005], w[1005];
int max(int a, int b)
{
	if (a > b)
		return a;
	else
		return b;
}
int main()
{
	int t, numbones, volume, i, j;
	cin >> t;
	while (t--)
	{
		//memset(m, 0, sizeof(m));
		cin >> numbones >> volume;
		for (i = 1; i <= numbones; i++)
			cin >> v[i];
		for (i = 1; i <= numbones; i++)
			cin >> w[i];
		for (i = 1; i <= numbones; i++)
		{
			for (j = 0; j <= volume; j++)
			{
				if (j >= w[i])
					m[i][j] = max(m[i - 1][j], m[i - 1][j - w[i]] + v[i]);
				else
					m[i][j] = m[i - 1][j];
			}
			
		}
		cout << m[numbones][volume];
	}
	//cin >> i;
	return 0;
}

把数组定义的位置换到函数外以后终于AC啦。
(一开始就是因为没改而wa好几次(;´д`)ゞ)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值