android开发中常见的问题

问题:
Androidmanifest xml does not exist or has incorrect root tag错误
解决;
Sync project with Gradle files更新一下,实在不行再invalidate and restart

问题:
Gradle sync failed: Cause: error in opening zip file Consult IDE log for more  details (Help | Show Log)

解决办法:

1,打开项目的build.gradle看下自己gradle的版本把网址复制一下,自己浏览器下https://services.gradle.org/distributions/gradle-3.3-all.zip

 2、打开 C:\Users\Administrator\.gradle\wrapper\dists\gradle-3.3-all\55gk2rcmfc6p2dg9u9ohc3hw9
 3、将下载的gradle-3.3-all.zip 替换到C:\Users\Administrator\.gradle\wrapper\dists\gradle-3.3-all\55gk2rcmfc6p2dg9u9ohc3hw9\gradle-3.3-all.zip
 4、重启Android studio的项目




问题:
you can format your XML resource int the 'standard' android way.Choose set form settting

解决:
直接点击打开然后设置标准格式化的xml文档就行了。




问题:
有些时候,即使导入了正确的包,但是还是出现
can not resolve symbol 'NameValuePair',然后这个函数(NameValuePair)一直显示红色,这是


Android api升级后不支持这些函数,然后解决办法;
打开build.gradle(Module)文件并复制这些依赖项:
compile 'com.google.http-client:google-http-client-android:+'


compile 'com.google.api-client:google-api-client-android:+'


compile 'com.google.api-client:google-api-client-gson:+'
复制useLibrary 'org.apache.http.legacy'下面buildToolsVersion这样:


android {
compileSdkVersion 23
buildToolsVersion "23.0.2"
useLibrary 'org.apache.http.legacy'

就这样。现在只是同步毕业文件。

很不错的一句话:

1. Android采用java语言进行开发。JDK 是整个Java的核心,包括了Java运行环境,Java工具和Java基础的类库。
2. Android SDK 指的是Android专属的软件开发工具包
软件开发工具包。被软件开发工程师用于为特定的软件包、软件框架、硬件平台、操作系统等建立应用软件的开发工具的集合。
3. Eclipse ADT 是 Eclipse 平台下用来开发 Android 应用程序的插件。

简单来说,
我们自己的程序要依靠java基本的类和API来编写,所以要JDK。
要用到各种android平台,好比android2.3等,便要有SDK。
要在 Eclipse上调用各种与android有关的插件,便要ADT。



发布了188 篇原创文章 · 获赞 115 · 访问量 49万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览