SWUSTOJ 0480 Locker Doors

问题描述:
There are n lockers in a hallway numbered sequentially from 1 to n. Initially, all the locker doors are closed. You make n passes by the lockers, each time starting with locker #1. On the ith pass, i = 1, 2, …, n, you toggle the door of every ith locker: if the door is closed, you open it, if it is open, you close it. For example, after the first pass every door is open; on the second pass you only toggle the even-numbered lockers (#2, #4, …) so that after the second pass the even doors are closed and the odd ones are opened; the third time through you close the door of locker #3 (opened from the first pass), open the door of locker #6 (closed from the second pass), and so on. After the last pass, which locker doors are open and which are closed? How many of them are open? Your task is write a program to output How many doors are open after the last pass? Assumptions all doors are closed at first.
输入:
a positive numbers n, total doors. n<=100000
输出:
a positive numbers ,the total of doors opened after the last pass.
输入样例:
10
输出样例:
3

解决:
这个题如果直接模拟题目中所述的过程,在输入规模较大的时候会超时。经过总结过后,我们发现最后仍然开着的门的编号都为平方数,比如如果有10扇门,最后依然保持开启的门的编号就为1、4、9
,共3扇。这样看这道题就很简单了,代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int main()
{
	int i,n,*lockers,count=0;
	scanf("%d",&n);
	lockers=(int*)malloc(sizeof(int)*(n+1));
    for(i=1;i<=n;i++)
    {
    	if(sqrt(i)==floor(sqrt(i)))//判断一个数是不是平方数
    	{
    		count++;
		}
	}
	printf("%d\n",count);
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值