HDU4122-Alice's mooncake shop(单调队列)

14 篇文章 0 订阅
2 篇文章 0 订阅

Alice’s mooncake shop

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4354 Accepted Submission(s): 1149

Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China’s Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.

Input
The input contains no more than 10 test cases.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be “Jan”, “Feb”, “Mar”, “Apr”, “May”, “Jun”, “Jul”, “Aug”, “Sep”, “Oct”, “Nov” or “Dec”. H and R are all integers.
All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o’clock belongs to the 1st hour, Jan 1st 2000 1 o’clock belongs to the 2nd hour, …… and so on.

(0< N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.

Output
You should output one line for each test case: the minimum cost.

Sample Input
1 10
Jan 1 2000 9 10
5 2
20
20
20
10
10
8
7
9
5
10
0 0

Sample Output
70
Hint

“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o’clock , there’s a consumer ordering 10 mooncakes.
Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
题目:HDU4122
题意:Alice开了一个月饼店,从头2000年1月1日0点开始营业,现在有一些订单,格式如Jan 1 2000 9 10,表示在2000年1月1日9点要10个月饼,给出一些时间做月饼的成本,并且一个月饼可以储存T天,每天储存的花费为S,现问完成所有订单的最小花费。
思路:在第n天需要交货的订单的最小成本显然为n-t天内min(cost[n-k]+k*s)(k<=t),cost[n-k]为第n-k天制作月饼的材料成本,很显然对于n我们只需要枚举其n-t天的成本即可,复杂度为n*k,当k很小时,不会超时,但是当k很大时,显然会T了。
我们需要使用单调队列维护一下这个cost最小值。
单调队列
我们假设一个队列满足一个三个性质:
1.队列中元素值的大小有序。
2.队列中元素下标从小到大(有序)。
3.队列中元素下标满足一个范围(n-t)。
对于本题,如果存在这样一个队列满足上述条件,队中元素的值的大小由小至大排序,那么队首的元素就是对应当前n最小的成本。代码实现:

void get_min()
{
    head=0;
    tail=-1;
    for(int i=1; i<=m; i++)
    {
        while(tail>=head&&(queues[tail].x+(i-queues[tail].pos)*s)>=a[i].x)tail--;
        queues[++tail]=a[i];
        while(queues[head].pos<(i-t))head++;
        nmin[i]=queues[head];
    }
}

上述代码,模拟一个队列,head表示队首坐标,tail表示队尾坐标,m即使总的元素长度,t是区间长度,对于每个元素a[i]我们让其从队尾开始比较,如果队尾元素比a[i]大,就将队尾元素弹出,直到在队中找到一个比a[i]小的元素(或者队列为空),将a[i]放在队尾,然后从队首开始,将下标不满足条件的元素全部弹出。
完成操作后队首元素即为当前i对应的最小花费。
本题,先求出每个日期对应的最小花费,然后计算总花费即可,获取时间时注意闰年的判断。
AC代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<vector>
#define met(s,k) memset(s,k,sizeof s)
#define scan(a) scanf("%d",&a)
#define scanl(a) scanf("%lld",&a)
#define scann(a,b) scanf("%d%d",&a,&b)
#define scannl(a,b) scanf("%lld%lld",&a,&b)
#define scannn(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define prin(a) printf("%d\n",a)
#define prinl(a) printf("%lld\n",a)
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
const int inf=2100;
const double eps=1e-4;
int n,m,s,t;
int head,tail;
char chamonth[13][5]= {"Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"};
int mday[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
struct node
{
    int x,pos;
} a[maxn],queues[2*maxn],nmin[maxn];
struct
{
    char month[10];
    int year,day,mnum,clock;
} order[2505];
bool judge_year(int x)
{
    return x%4==0&&x%100||x%400==0;
}
void get_min()//单调队列
{
    head=0;
    tail=-1;
    for(int i=1; i<=m; i++)
    {
        while(tail>=head&&(queues[tail].x+(i-queues[tail].pos)*s)>=a[i].x)tail--;
        queues[++tail]=a[i];
        while(queues[head].pos<(i-t))head++;
        nmin[i]=queues[head];
    }
}
int get_month(int x)
{
    for(int i=0; i<11; i++)
        if(strcmp(chamonth[i],order[x].month)==0)return i+1;
    return 12;
}
int get_time(int x)
{
    int hour=0;
    for(int i=2000; i<order[x].year; i++)
    {
        if(judge_year(i))hour+=366*24;
        else hour+=365*24;
    }
    int nmonth=get_month(x);
    for(int i=1; i<nmonth; i++)
    {
        hour+=24*mday[i];
        if(i==2)if(judge_year(order[x].year))hour+=24;
    }
    hour+=(order[x].day-1)*24+order[x].clock+1;
    return hour;
}
int main()
{
    while(scann(n,m),n+m)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%s%d%d%d%d",order[i].month,&order[i].day,&order[i].year,&order[i].clock,&order[i].mnum);
        }
        scann(t,s);
        for(int i=1; i<=m; i++)scan(a[i].x),a[i].pos=i;
        get_min();
        ll ans=0;
        for(int i=1; i<=n; i++)
        {
            int time=get_time(i);//获取订单时间
            if(time>m)continue;
            ans+=(nmin[time].x+(time-nmin[time].pos)*s)*order[i].mnum;
        }
        prinl(ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值