HDOJ 1059 Dividing(多重背包+二进制优化)

12 篇文章 0 订阅

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.

题目大意:输入6个数字,代表价值为1-6的大理石的块数,要求判断是否能够将这些大理石分成价值相等的两份。

题解:将每种大理石进行二进制拆分,0 1背包DP即可。不懂二进制优化的这里开个传送门

http://blog.csdn.net/lyhvoyage/article/details/8545852
这篇博客里有证明,很详细

AC代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int inf = -INT_MAX;
int main()
{
    int dp[101005];
    int a[6];
    int m[23000];
    int temp;
    int t = 1;
    while(scanf("%d%d%d%d%d%d", &a[0], &a[1], &a[2], &a[3], &a[4],&a[5]))
    {
        if(!(a[0] || a[1] || a[2] || a[3] || a[4] || a[5]))break;
        temp = 1 * a[0] + 2 * a[1] + 3 * a[2] + 4 * a[3] + 5 * a[4] + 6 * a[5];
        int n=0;
        if(temp % 2)//特判不能整除2直接NO
        {
            printf("Collection #%d:\nCan't be divided.\n", t++);
            printf("\n");
            continue;
        }
        for(int i=0;i<6;i++)//二进制优化
        {
            for(int j=1;j<=a[i];j*=2)
            {
                m[n++]=j*(i+1);
                a[i]-=j;
            }
            if(a[i]>0)
            {
                m[n++]=a[i]*(i+1);
            }
        }
        temp /= 2;//背包容量为sum/2
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i = 0; i < n; i++)
        {
            for(int j = temp;  j>= m[i]; j--)
            {
                if(dp[j-m[i]])dp[j]=1;//价值等于重量的物品,只需标记是否装满
            }
        }
        if(dp[temp])printf("Collection #%d:\nCan be divided.\n", t++);
        else printf("Collection #%d:\nCan't be divided.\n", t++);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值