hdu 6011 Lotus and Characters

Lotus has n n kinds of characters,each kind of characters has a value and a amount.She wants to construct a string using some of these characters.Define the value of a string is:its first character's value*1+its second character's value *2+...She wants to calculate the maximum value of string she can construct.
Since it's valid to construct an empty string,the answer is always 0 ≥0。 Input
First line is T(0T1000) T(0≤T≤1000) denoting the number of test cases.
For each test case,first line is an integer n(1n26) n(1≤n≤26),followed by n n lines each containing 2 integers vali,cnti(|vali|,cnti100) vali,cnti(|vali|,cnti≤100),denoting the value and the amount of the ith character.
Output
For each test case.output one line containing a single integer,denoting the answer.
Sample Input
2
2
5 1
6 2
3
-5 3
2 1
1 1
Sample Output
35
5
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<set>

using namespace std;

#define  mem(x,y) memset(x,y,sizeof(x))
struct node
{
	int num, value;
	int f=0;
	friend bool operator<(const node &a, const node &b)
	{
		return a.value < b.value;
	}
};
node zi[10000];
int n;
int jia(int i)
{
	int t = 0;
	for (int j = 1; j <= i; j++)
	{
		t += j;
	}
	return t;
}
int main()
{
	
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		int sum=0;
		for (int i = 0; i < n; i++)
		{
			scanf("%d %d", &zi[i].value, &zi[i].num);
			if (zi[i].value > 0)
			{
				sum += zi[i].num*zi[i].value;
			}
		}

		sort(zi, zi + n);
		int a;
		int ans=0;
		int temp = 0;
		for (int i = n-1,k=1; i >= 0; i--)
		{
			int nowans = ans;
			for (int j = 0; j < zi[i].num; j++)
			{
				nowans = temp + nowans + zi[i].value;
				if (nowans > ans)
				{
					ans = nowans;
					a = zi[i].value;
					temp += a;
				}
				else if (nowans < ans)
				{
					break;
				}
			}
		}
		printf("%d\n", ans);
	
	}
	return 0;
}

//by swust_t_p
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值