card card card

card card card

As a fan of Doudizhu, WYJ likes collecting playing cards very much.
One day, MJF takes a stack of cards and talks to him: let's play a game and if you win, you can get all these cards. MJF randomly assigns these cards into n heaps, arranges in a row, and sets a value on each heap, which is called "penalty value".
Before the game starts, WYJ can move the foremost heap to the end any times.
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the penaltyvalue .
If at one moment, the number of cards he holds which are face-up is less than the penaltyvalue , then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end.So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all "penalty value" is exactly equal to the number of all cards.
 

Input
There are about 10 test cases ending up with EOF.
For each test case:
the first line is an integer n ( 1n106 ), denoting n heaps of cards;
next line contains n integers, the i th integer ai ( 0ai1000 ) denoting there are ai cards in i th heap;
then the third line also contains n integers, the i th integer bi ( 1bi1000 ) denoting the "penalty value" of i th heap is bi .
 

Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.
 

Sample Input
   
   
5 4 6 2 8 4 1 5 7 9 2
 

Sample Output
   
   
4
Hint
[pre] For the sample input: + If WYJ doesn't move the cards pile, when the game starts the state of cards is: 4 6 2 8 4 1 5 7 9 2 WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can't pay the the "penalty value" of the third pile, the game ends. WYJ will get 12 cards. + If WYJ move the first four piles of cards to the end, when the game starts the state of cards is: 4 4 6 2 8 2 1 5 7 9 WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards. It can be improved that the answer is 4. **huge input, please use fastIO.** [/pre]


题目大意:WYJ十分喜欢玩扑克游戏,有一天他将扑克分为n堆,有一个惩罚值初始为0,每一对的惩罚值为上边的数减去下边的数,当惩罚值小于零停止拿牌。WYJ可以在游戏开始前将前面的k(k<n)堆牌拿到后面,问怎样拿才能使WYJ得到的牌最多(的一行的数为每一堆WYJ得到的牌数)。求k。
题目分析:相当于是一个环状的牌告诉起点,问从起点后几位开始拿能得到最多的牌,既然是环状的,那么我们可以延长一倍数组,用延长后的数组求从第几位开始拿得到的牌数最多,当然这个“ 第几位 ”应该是小于数组的长度的。



#include<cstdio>
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
typedef long long ll;
struct node{
	int a,b,c;
};
node p[2000005];
int main()
{
	int n,k;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<n;i++)
			scanf("%d",&p[i].a);
		for(int i=0;i<n;i++){
			scanf("%d",&p[i].b);
			p[i].c=p[i].a-p[i].b;
			p[i+n]=p[i];
		}
		int maxx=p[0].c,ans1=0,ans=0,left1=0,right1=0,left=0,right=0;
		for(int i=0;i<2*n;i++){
			ans1+=p[i].c;
			ans+=p[i].a;
			if(ans1>=0){
				right1=i;
				if(ans>maxx){
					left=left1;
					right=right1;
					maxx=ans;
				}
			}
			else{
				right1=i;
				if(ans>maxx){
					left=left1;
					right=right1;
					maxx=ans;
				}
				ans1=ans=0;
				left1=i+1;
			}
			if(right1-left1>=n||left1>=n)
				break;
		}
		cout<<left<<endl;
	}
	return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值